2 Replies Latest reply on Jun 28, 2016 1:19 PM by rob.wu

    Tableau not connecting to Drill ODBC of Mapr Cluster

    Charan Thota

      I am having problem connecting to Tableau with Drill DSN , Tableau just hangs up. When we create the ODBC Driver it says succesfully connected to data source. I tried connecting using Drill explorer to check if there is any connectivity issues it was able to connect and query. What would be the issue here with Tableau?

       

      I am using Tableau 9.3 Full Trial version in Windows 8.1

       

      MapR Configuration.png

       

      Tableau_Error.png

       

      pastedImage_0.png

        • 1. Re: Tableau not connecting to Drill ODBC of Mapr Cluster

          Hi Charan Thota, Lisa Sawin

           

          First check the driver version. If you look at the Tableau logs we will echo back the ODBC version level the driver reports. Search the logs for a statement like: ODBCProtocol: driver ODBC version: 03.52. The number at the end indicates the ODBC version level. If it is less than 03.00, thn the driver needs to be upgraded.

          If you get warnings when you connect about capabilities not supported, check with your database vendor to see if they have an updated driver that supports more capabilities. Not all drivers will work with Tableau.

           

          If you are connecting to a database for which we have a named connection option, then use the named connection. The named choices are optimized for the particular database where Tableau has specific knowledge of the databases capabilities.

           

          Let me know if this helped you or if your require more assistance

          • 2. Re: Tableau not connecting to Drill ODBC of Mapr Cluster
            rob.wu

            Hi Charan Thota,

             

            This seems to be related to this open ticket: [DRILL-1343] Drill should time out after short time if a storage plugin is unresponsive. - ASF JIRA

             

            As a work around, I found that adding the following settings into the hbase configuration solves the hang issue.

                "hbase.zookeeper.session.timeout": "60000",

                "hbase.zookeeper.recovery.retry": "0",

                "hbase.client.retries.number": "1"

            After updating the storage config, make sure you restart all the drillbits.

             

            If you are trying to access tables on hbase, make sure you have maprdb turn on as they will be listed there with the default settings.

            And if you don't require hbase, turning it off and restart drillbits also resolved the issue for me, too.

             

            Cheers

            2 of 2 people found this helpful