3 Replies Latest reply on Mar 14, 2016 12:25 PM by Dan Cory

    Live connecting ignores inner join

    Leo Kaplun

      I'm trying to create a date parameter for my data-set. The data has date for only about 2 year.

      My data is being INNER JOINED with a Date dimension which has dates from 1990-2098.

      So when I create the Date & Time parameter using the live connection and I set the Range of Values from 'Set from Field', it totally ignores the INNER JOIN and gives me all the dates from the Date Dim.

      But when I'm running from the extract, then the date ranges are correct, only those from the inner join. Is there a way to fix that? Is it a bug?


      Live Connection:

      live connection.PNG



        • 1. Re: Live connecting ignores inner join
          Tharashasank Davuluru

          HI Leo ,


          Step 1: Create Start Date and End Date Parameters

          1. In the Data window, click the drop-down arrow at the top right of Dimensions, and then select Create > Parameter.
          2. In the Create Parameter dialog box, name the parameter. In the example workbook, the parameter is named Start Date.
          3. Under Data Type, select Date & time.
          4. Under Allowable values, select Range.
          5. Click Set from Field and select the date field. In the example workbook, the date field is named Order Date.
          6. Click OK.
          7. Right-click the Start Date parameter and then select Show Parameter Control.
          8. Repeat steps 1-7 to create the End Date parameter.
          • 2. Re: Live connecting ignores inner join
            Leo Kaplun

            Thanks for that. I have done that, it's what Tableau recommends we do to create a date prameter.

            But it's still seems weird that the Inner Join is ignored in this case.

            • 3. Re: Live connecting ignores inner join
              Dan Cory

              This is intentional. It's done for performance reasons - it is usually much faster to get the domain of a dimension table if you don't also check that all the values are in the fact table. It's also useful in case data is added in the future.


              Once you create an extract, everything is pre-joined so there's no need for this optimization.