1 Reply Latest reply on Feb 25, 2016 1:02 AM by Amanjot Klair

    Using cube dimension in tabcmd export

    Amanjot Klair

      Hi Everyone,

       

      Here is a problem i am struggling with for quite some time now. I am trying to export a workbook into PDF file and i alongwith that i want to download the PDF file with filter applied on one or more Dimension. I have done this earlier but not with a cube data source, while working with extract this works just fine but while working with cube somehow the filter is not getting applied. I have tried many version of the command but still the dashboards are not getting filtered though they are getting downloaded. Which means tableau server is reading my command as correct but not applying the filters. Below are the different versions of command i have used.

       

      tabcmd export "workbookname/dashboardname?Fiscal%20Year=2016" --fullfpdf

      tabcmd export "workbookname/dashboardname?[Fiscal%20Year]=2016" --fullpdf

      tabcmd export "workbookname/dashboardname?[Calendar].[Fiscal%20Year]=2016" --fullpdf

      tabcmd export "workbookname/dashboardname?[Calendar].[Fiscal%20Year].&[2016]" --fullpdf

       

      All these commands download the workbook but ignoring the year filter supplied value. Has anyone tried this earlier? Would appriciate your help.

       

      Additionally i would like to ask that i have read alot of posts which talk about taking these filters from the URL of the dashboards when they are being used. So apply the filter on the dashboard and take these values from the URL at the top however when i use my dashboard i don't see any values in the URL of the browser no matter while using cubes or extracts can someone tell me if there is something missing in my tableau server?

       

      Thanks in advance..

      -Amanjot

        • 1. Re: Using cube dimension in tabcmd export
          Amanjot Klair

          Finally after strugling for so many days i have solved the mystery. If the dimension is a unique dimension then the first one is correct and if not then the 3rd one to be used. Means if there is only one dimension by that name among all the hierarchies then the first one to be used and if the same dimension name exists in other hierarchies as well then use the 3rd one. Pretty confusing though..

          2 of 2 people found this helpful