2 Replies Latest reply on Dec 15, 2016 2:22 PM by kaifeng zeng

    Tabjolt -  Failed to set up load test session

    Kai-Ming Cheah

      Downloaded Tabjolt for Tableau Server 9.0 from Here

      ,and have stepped through the guide here

       

      • Postgres installed, scripts applied:
      • Updated server path and user creds in  ServerTestConfig.yaml   ---- question: do the   # server database connection information  need to updated????  no mention of this anywhere online or the youtube guide.
      • Add dashboard links into vizpool.csv ( taken out https:  , ensure leading / and ending /[magic number]
        • e.g   /site/Customer/views/1inService/ActualvsTargetvsForecast/1
      • have followed the youtube guide.
      • googled the error messages

       

      still getting errors....

       

      what am i doing wrong?

       

      I've noticed i get the same error even when i put in an incorrect Server Path.

       

      can someone see anything clearly obvious i've done wrong?

       

       

       

       

      C:\Users\M005464\Tabjolt>go --t=testplans\ViewVizLoadTest.jmx --d=240 --c=1

      Perf harness is started with parameters: --rootPath=C:\Users\M005464\Tabjolt --t

      =testplans\ViewVizLoadTest.jmx --d=240 --c=1

      -------------start collecting JMX counters--------------

      Output File:C:\Users\M005464\Tabjolt/results/2016-02-18_18-24-44/jmxcounter.tsv

      -------------start collecting Zabbix counters--------------

      Output File:C:\Users\M005464\Tabjolt/results/2016-02-18_18-24-44/zabbixcounter.t

      sv

      -------------start windows performance counters collection-------------

      Output File:c:\users\m005464\tabjolt/results/2016-02-18_18-24-44/wincounter.tsv

      -------------start Jmeter load test run-------------

      Output file: C:\Users\M005464\Tabjolt/results/2016-02-18_18-24-44/result.jtl

      Command: [C:\Users\M005464\Tabjolt/bin/jmeter.bat, -n, -t=C:\Users\M005464\Tabjo

      lt//testplans\ViewVizLoadTest.jmx, -j=C:\Users\M005464\Tabjolt/logs/jmeter_2016-

      02-18_18-24-44.log, -JthreadCount=1, -Jduration=240, -JconfigFolderPath=C:\Users

      \M005464\Tabjolt/config/, -Jlogpath=C:\Users\M005464\Tabjolt/results/2016-02-18_

      18-24-44/result.jtl]

      Created the tree successfully using C:\Users\M005464\Tabjolt//testplans\ViewVizL

      oadTest.jmx

      Starting the test @ Thu Feb 18 18:24:49 EST 2016 (1455780289931)

      Waiting for possible shutdown message on port 4445

      FATAL [2016-02-18 18:24:50,477][setUp Thread Group 1-1] (LoadSessionSetup.java:4

      5)   - Failed to set up load test session. Stopping the test run.

      java.lang.NumberFormatException: For input string: "1inService"

              at java.lang.NumberFormatException.forInputString(Unknown Source)

              at java.lang.Integer.parseInt(Unknown Source)

              at java.lang.Integer.parseInt(Unknown Source)

              at com.tableausoftware.test.server.perfTestSuite.ViewFetcher.populateViz

      FromCSV(ViewFetcher.java:217)

              at com.tableausoftware.test.server.perfTestSuite.ViewFetcher.initialize(

      ViewFetcher.java:73)

              at com.tableausoftware.test.server.perfTestSuite.LoadSessionSetup.runTes

      t(LoadSessionSetup.java:39)

              at org.apache.jmeter.protocol.java.sampler.JavaSampler.sample(JavaSample

      r.java:191)

              at org.apache.jmeter.threads.JMeterThread.process_sampler(JMeterThread.j

      ava:429)

              at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:257)

              at java.lang.Thread.run(Unknown Source)

      Tidying up ...    @ Thu Feb 18 18:24:50 EST 2016 (1455780290540)

      ... end of run

      Jmeter process has exited. Waiting for the other processes to exit.