2 Replies Latest reply on Mar 8, 2016 1:58 PM by Ben Lower

    Problem with SDK connecting to https

    Joao Correia

      Hi,

       

      I've downloaded and installed the Tableau SDK for Python (64-bit) Linux.

      It created the extract fine and it upload to our server without any problems.

       

      When I try to publish to the client Tableau server (which uses https) I get the following:

       

      Error: CURL_ERROR - Problem with the SSL CA cert (path? access rights?)

       

      I've tried curl and it seems to connect fine.

       

      curl -vvv https://tableau.domain.com

      * Rebuilt URL to: https://tableau.domain.com/

      * Hostname was NOT found in DNS cache

      *   Trying 171.67.37.19...

      * Connected to tableau.domain.com (171.67.37.19) port 443 (#0)

      * successfully set certificate verify locations:

      *   CAfile: none

        CApath: /etc/ssl/certs

      * SSLv3, TLS handshake, Client hello (1):

      * SSLv3, TLS handshake, Server hello (2):

      * SSLv3, TLS handshake, CERT (11):

      * SSLv3, TLS handshake, Server key exchange (12):

      * SSLv3, TLS handshake, Server finished (14):

      * SSLv3, TLS handshake, Client key exchange (16):

      * SSLv3, TLS change cipher, Client hello (1):

      * SSLv3, TLS handshake, Finished (20):

      * SSLv3, TLS change cipher, Client hello (1):

      * SSLv3, TLS handshake, Finished (20):

      * SSL connection using ECDHE-RSA-AES256-GCM-SHA384

      * Server certificate:

      * subject: C=US; postalCode=94305; ST=CA; L=Domain; street=450 Serra Mall; O=Domain; OU=CBMH; OU=PlatinumSSL; CN=tableau.domain.com

      * start date: 2014-10-07 00:00:00 GMT

      * expire date: 2017-10-06 23:59:59 GMT

      * subjectAltName: tableau.domain.com matched

      * issuer: C=US; ST=MI; L=Ann Arbor; O=Internet2; OU=InCommon; CN=InCommon RSA Server CA

      * SSL certificate verify ok.

      > GET / HTTP/1.1

      > User-Agent: curl/7.35.0

      > Host: tableau.domain.com

      > Accept: */*

      >

      < HTTP/1.1 200 OK

       

      Any ideas?

       

      Thanks

      Joao

        • 1. Re: Problem with SDK connecting to https
          Bernd Wiswedel

          We have the same problem. The certificate seems valid when the URL is entered to any standard browser (https://dub01.online.tableau.com/ - "verified by thawte, Inc.") but it fails when used through the API. We are using Java and this is the stacktrace I'm getting:

          com.tableausoftware.TableauException: Problem with the SSL CA cert (path? access rights?)

              at com.tableausoftware.server.ServerConnection.connect(Unknown Source)

              at org.knime.ext.tableau.SendToTableauNodeModel.execute(SendToTableauNodeModel.java:136)

              at org.knime.core.node.NodeModel.execute(NodeModel.java:719)

              at org.knime.core.node.NodeModel.executeModel(NodeModel.java:563)

           

          Another things I tried (and failed):

          o Using "sso.online.tableau.com" instead as that is the website url associated with the certificate

          o Disabling all SSL verfication in the JVM (wouldn't be a long-term fix anyway --- but just for the sake of diagnosis)

           

          Both attempts didn't work which leaves me to believe that the problem is somewhere in in the API/native code.

          • 2. Re: Problem with SDK connecting to https
            Ben Lower

            Answer posted here. tl;dr -> we have a bug right now and SSL won't work in Linux version of SDK.