6 Replies Latest reply on Feb 5, 2016 6:32 AM by Toby Erkson

    Viewing more than 1 dashboard in Chrome/MS Edge

    Anthony Nguang

      HI Guys,

       

      I have just completed 18 dashboards for my company and was very excited to show it off to my directors and all.

      One problem came out during the presentation was that I am not able to view more than 1 dashboard at a time.

       

      As soon as i open the 2nd dashboard in a new window the first dashboard will automatically logout. making it impossible to view and navigate more than 1 dashboard.

       

      Does anyone know of any solution to overcome this?

       

      Thank you

      Tony

        • 1. Re: Viewing more than 1 dashboard in Chrome/MS Edge
          Jeff Strauss

          What type of authentication are you using?  We were running into an issue with multiple reports open within Chrome.  As soon as we changed the protect_sessions option, the issue went away.  I would suggest to test it out first on a dev platform.

           

          tabadmin set vizqlserver.protect_sessions false

           

          tabadmin set options

           

           

           

          An error occurred communicating with the server (403)

          If Tableau Server is configured for trusted authentication, you may receive this error after

          opening a new view in a browser and attempting to navigate back to views you'd opened

          1. earlier. Tableau Server provides protection against unauthorized reuse of VizQL sessions

          through the tabadmin set option vizqlserver.protect_sessions, which is set to true by default.

          Because Tableau Server is configured for trusted authentication, you may not also need to

          enable vizqlserver.protect_sessions. To disable it, use set on page 479 to change it

          to false.

          • 2. Re: Viewing more than 1 dashboard in Chrome/MS Edge
            Anthony Nguang

            Hi Jeff

             

            Thanks for your reply.

            I have followed your instruction and set the tabadmin set vizqlserver.protect_sessions false however this did not resolve my issue.

            I am still not able to browse the dashboard in more than 1 view by using Chrome Version 48.0.2564.97 m.

             

            Please let me know if you have an alternative solution.

             

            Thank you

            • 3. Re: Viewing more than 1 dashboard in Chrome/MS Edge
              Vien Hua

              Hi Anthony, did you setup Tableau Server or did someone else do it for you? Like Jeffrey asked, do you know what authentication method is being used? Are the dashboards being embedded in another website? It sounds like trusted authentication may be in use... correct?

              • 4. Re: Viewing more than 1 dashboard in Chrome/MS Edge
                Anthony Nguang

                Hi Vien,

                 

                To reply your questions

                1. We are using Local Authentication. No Active Directory

                2. Not embedded in any website

                 

                We are running Tableau Server 9.2 (before our upgrade everything was ok)

                 

                Our server is hosted in MS Azure with 32GB RAM and 4 Core Processor.

                 

                Please do let me know if this is a problem with version 9.2 or any other setting i should check?

                 

                Thank you

                • 5. Re: Viewing more than 1 dashboard in Chrome/MS Edge
                  Vien Hua

                  Hmm that is strange. I would suggest that you open a case with technical support if you haven't already. In the meantime, have you changed the tabadmin timeout settings? How are you opening the second dashboard? What if you have the main UI window opened and then click on the two different dashboards and have them open in a new window. Does that work?

                  • 6. Re: Viewing more than 1 dashboard in Chrome/MS Edge
                    Toby Erkson

                    Anthony Nguang wrote:

                     

                    Hi Jeff

                     

                    Thanks for your reply.

                    I have followed your instruction and set the tabadmin set vizqlserver.protect_sessions false however this did not resolve my issue.

                    ...

                    Just to make sure, did you do the following as part of the instructions?