1 2 Previous Next 19 Replies Latest reply on Feb 22, 2017 4:52 PM by Rafael Schaffer

    TabCmd Get - 302 error

    Amy Augustine

      Hi I am new to Tableau.  I have been attempting to work with TabCmd and have successfully logged in to our server.  I have also been able to do a few other commands with TabCmd such as refresh extracts.  My goal now is to download a tbwx file from the server.  I am using the following syntax :   tabcmd get "/workbooks/abc.twbx" -f "D:\Scripts\Tableau\abc.twbx"


      My issue is that it appears to be connecting and then returns,



      ' Redirecting to Http://tableauserver/#/workbooks/55/views '

      *** 302 Found


      I am not sure if I need to connect to another url instead in order to allow it to connect?   or if so,  how I determine what this is?  I have tried then typing this url into the get command but I receive a 404 - file not found error.


      I am an admin and have full rights to all of the workbooks.


      Thanks in advance for any help. 

        • 1. Re: TabCmd Get - 302 error
          Jeff Strauss

          do you have a workbook called abc.twbx?  the 302 may indicate that it can't find that workbook.  Also, is it on the default site?

          • 2. Re: TabCmd Get - 302 error
            Amy Augustine

            Thank you for your reply.  Yes my worksheet is called abc .  I am not sure I thought it was finding it since I am not seeing a 404 error, which I have when not typing name correctly.  My workbook is in a 'project' called Default..  Not sure if this is what you are referring to? 

            • 3. Re: TabCmd Get - 302 error
              Amy Augustine

              Thank you for your reply Jeffrey.  I do have  a workbook called abc.  I have also tried without the .tbwx.  It is in a project called ‘Default’.  I am not sure if this is what you are asking.  It does not produce a 404 error, which is what is received when I incorrectly type the file name.

               

              amy augustyn

              business analyst

              (800) 511-9172 x 180

              • 4. Re: TabCmd Get - 302 error
                Jeff Strauss

                do you have multiple sites within your Tableau server?

                • 5. Re: TabCmd Get - 302 error
                  Amy Augustine

                  I do not believe so, but how do I determine this for certain?   Our old admin left the company.

                  • 6. Re: TabCmd Get - 302 error
                    Amy Augustine

                    Also I am able to use commands such as the following and they are successful.

                     

                     

                     

                    tabcmd refreshextracts --server http://server --username username password PWproject "default"  --workbook  "abc"

                     

                     

                     

                    It is the previous command that I am having an issue with, so I am thinking Tabcmd  is finding the  site, etc.

                    • 7. Re: TabCmd Get - 302 error
                      Jeff Strauss

                      when you login to tableau server, does it prompt you for which site to login to?  If not, then it's probably a single site deployment.

                       

                      Also, do you happen to know if your admin deployed with SSL or https turned on?  this could be another possibility of the 302 error and maybe resolved if you add --no-certcheck onto the end of the tabcmd.

                      • 8. Re: TabCmd Get - 302 error
                        Amy Augustine

                        Hi – thanks again for your replies.  I am not prompted, so I am assuming we are a single site.

                         

                         

                        I also do not  know if they did use ssl or https,  but I did try the command with the --no-certcheck option and received the same error.

                         

                        I did also try the following command, just for fun ‘tabcmd export “Test/DS.pdf” –fullpdf’

                         

                        and I received a different error at least ☺ -  This one stated ‘***Failed to create a VizQ session on the server’

                         

                        I am not sure if this gives any indication as to the underlying issue?

                         

                        Also I am able to download the workbook itself using the Download button from Tableau Server using Google Chrome,  however when I attempt to use IE I receive an xml parsing error and the workbook will not open.  Again I am not sure how or if these are related.

                        • 9. Re: TabCmd Get - 302 error
                          Jeff Strauss

                          sorry none of my suggestions have panned out.  the id that you login with on tabcmd, does it have permission to download the workbook?  also, try changing it from twbx to twb just to see what this does.

                          • 10. Re: TabCmd Get - 302 error
                            Amy Augustine

                            I appreciate your help.  I am using the correct syntax though right?      I just want to verify. I have server admin permissions and it is this id I am downloading with. When I check the workbooks permissions, the id has download privileges.

                             

                            I believe it is finding the correct workbook from my command, however it is redirecting.  For example,   when I am hovering over the workbook named ‘Test’ in Tableau Server or when I click on it and go to the URL,   it shows http://server/workbooks/55/views    rather than http://server/workbooks/Test/views.  When the 302 error appears this is the exact URL displayed.

                             

                            This  changes for each workbook –.   For abc  - it is http://server/workbooks/57/views  and is the same on the server as well as in the error.  I have tried to use these numbers instead of the workbook names, but this doesn’t help.

                             

                            Is this normal behavior or could something be causing it to redirect on our environment only?

                             

                            Thank you!

                            • 11. Re: TabCmd Get - 302 error
                              Amy Augustine

                              Ok – well I understood you could install and run TabCmd Anywhere as it says in the documentation.  Apparently this is not the case.  I finally decided to just install on our Tableau server, which we were trying to avoid and VOILA !  I am not sure why this was happening still and would rather not have it on our server, but at least I have a file!

                               

                              Thanks for your help!

                               

                              Amy

                              • 12. Re: TabCmd Get - 302 error
                                Jeff Strauss

                                well, I'm glad you got it working.  We run tabcmd get all the time, but do it within the server environment so that perhaps explains why we haven't seen the 302 error.

                                • 13. Re: TabCmd Get - 302 error
                                  Robert Lagus

                                  I'm coming back to this thread over and over again when I google around on a solution to my issue, my "302 Found" error.

                                   

                                  I only have one instance and tabcmd running on the server itself.

                                   

                                   

                                  Here's the output I get:

                                  tabcmd get "/views/ClickAnalysis/ClickAnalysis.twbx" -f "C:\Users\tableau\clickanalyssi.twbx"

                                  ===== Continuing previous session

                                  =====     Server:   http://tableauserver.com:80

                                  =====     Username: reports

                                  ===== Requesting '/views/ClickAnalysis/ClickAnalysis.twbx' from the server...

                                  ===== redirecting to http://tableauserver.com/#/views/ClickAnalysis/ClickAnalysis%2etwbx

                                    *** 302 Found

                                   

                                  Eg. are there any place where can I get additional logging from the get command?

                                  • 14. Re: TabCmd Get - 302 error
                                    Jeff Strauss

                                    is it a single node server with all default ports and no-SSL configured and the default site?  If so, try running your tabcmd login with http://localhost to see if this helps.

                                    1 2 Previous Next