1 Reply Latest reply on Aug 23, 2015 10:39 PM by Bora Beran

    Cannot run procedure

    Luc Jiang

      My procedure is like below:

       

      create procedure

      @xx datetime

      as

      begin

       

      select *

      into #temp

      from T_XX

       

      select *

      from #temp

       

      end

       

      And tableau cannot run that telling me the procedure doesnot return a dataset...

       

      and I have tried and found that once you have a parameter, Tableau cannot run, and once you need to create temp tables, tableau cannot run...

       

      But without the using of temp tables, the procedure will take too much time...

       

      What can i do to resolve it ?

        • 1. Re: Cannot run procedure
          Bora Beran

          The reason why the procedure fails is that you didn't set nocount on.

           

          There is a long discussion in this thread.

           

          Using stored procedures and temp tables

           

          You should get a good performance without a temp table in your scenario since Tableau already creates a temp table for you then queries that table. With your procedure, Tableau will still get the results from the second select statement and create another temp table and then query that.

          1 of 1 people found this helpful