1 Reply Latest reply on Sep 25, 2015 12:58 PM by diego.medrano

    Error in using dataextract.jar  Unable to load library 'DataExtract'

    Sarath Chambyil

      Hi, I am using dataextract.jar which is giving me the following error..

       

      java.lang.UnsatisfiedLinkError: Unable to load library 'DataExtract': The specified module could not be found.

       

        at com.sun.jna.NativeLibrary.loadLibrary(NativeLibrary.java:194)

        at com.sun.jna.NativeLibrary.getInstance(NativeLibrary.java:283)

        at com.sun.jna.NativeLibrary.getInstance(NativeLibrary.java:244)

        at com.sun.jna.Native.register(Native.java:1065)

        at com.tableausoftware.DataExtract.Extract.<clinit>(Unknown Source)

        at AppZip.generate(AppZip.java:149)

        at AppZip.main(AppZip.java:213)

       

      I saw a post in community.tableau.com of same problem but can't find perfect solution,I tried all the solutions mentioned in the below post, still getting the same error. My system is windows 7 64bit, using Eclipse Luna. dataextract.jar and jna.jar are of 64bit only.

      Unable to import the Extract API jar files getting below error

      Please give me the solution as soon as possible.

      Thanks