2 Replies Latest reply on Jul 10, 2015 7:54 AM by Toby Erkson

    Bad "Manage my subscription settings" URL

    Toby Erkson

      I created a test workbook and subscription to test the VizAlerts.  It worked, yeay!  However, the link to subscriptions produces a bad URL.

      The email:

                                          

      When I click the link it produces this URL, which fails:

      http://myCompany.com.theDomain.com/#/user/theDomain.com/terkson/subscriptions

      where "myCompany.com" is where the Tableau Server is and "theDomain.com" is the Active Directory path (?).

      Thus it looks as though the AD path is being suffixed to the Tableau Server URL and it doesn't need to be.

        • 1. Re: Bad "Manage my subscription settings" URL
          Matt Coles

          Looking back at the vizalerts.yaml file you sent, I missed that you'd specified the FQDN for the server value. I should clarify in the comment and docs that it's the short version that is needed there, e.g., "myServer" as opposed to "myServer.theDomain.com". The server.domain entry is what I'm using to append to the server value to get the FQDN and construct that link, among other things.

           

          So if you change that, I suspect it will fix the link problem...

          1 of 1 people found this helpful
          • 2. Re: Bad "Manage my subscription settings" URL
            Toby Erkson

            Ah, got it.  I made the change and it worked, thanks Matt.

             

            I misunderstood "server domain" and used our AD fully-qualified domain name.  So now "server" is just the first part of the FQDN and "server domain" is the rest of it.