8 Replies Latest reply on Jul 16, 2015 3:47 AM by Srinivas K

    Tabcmd issue

    Srinivas K

      Hi , I am trying o execute below TABCMD command from local sytem ( not server machine), tabcmd creategroup "fin_users", But it is giving error  saying -- creating group "fin_users" on the server ... *** 404 not found.   I was able to publish .twbx file using tabcmd. But not sure why I am getting the error while creating group using tabcmd.  Can any one help me on this.

        • 1. Re: Tabcmd issue
          vishwanath Pendyala

          Have you logged in to specific site before creating group ?

           

          Thanks

          Vishwa

          • 2. Re: Tabcmd issue
            Srinivas K

            Thanks Vishwanath for your reply.

             

            We have not created specific site in our project. I am assuming If I do not mention any site name while logging , that means I am connecting to default site.

             

            Please suggest me If I need to add any site name to the syntax.

             

            Thank you!

            • 3. Re: Tabcmd issue
              Sankarmagesh Rajan

              Hi Srini,

               

              First login tabcmd and

              create group

              tabcmd creategroup "Development"

               

              add users in group

              tabcmd addusers "Development" --users "users.csv"

               

              Thanks

              sankar

              • 4. Re: Tabcmd issue
                Srinivas K

                Hi Sankar rajan,

                 

                I have followed the above steps, but still I am getting error "404 not found"

                 

                Tried below

                 

                1) Loging into site

                tabcmd login –s <server> -u userid -p password

                 

                2)Publish the Workbook

                 

                tabcmd publish "
                C:\Test\Trendanalysisnew.twbx" -n "Trend_Analysis new"

                 

                I was succeed publishing the workbook

                 

                3) logged out of server

                 

                4) Again logged in  ( repeated Step1)

                 

                5)tabcmd creategroup "developmenttest"

                 

                Got the below error

                 

                Creating group ‘development’ on the server …

                  *** 404 not found

                 

                 

                 

                I have my default site, I have tried creating New site  from server and tried to loging into the server and site

                 

                1) Login

                tabcmd login –s <server> -t  <Site> -u userid -p password

                succeded

                2)Creating group

                tabcmd creategroup "developmenttest1" -t <Site>

                 

                got error

                Creating group ‘developmenttest1'on the server …

                  *** 404 not found

                 

                also tried

                3)

                logged into serverfor that site again ( repeated the step1)

                 

                 

                4)create group

                 

                tabcmd creategroup "developmenttest2"

                 

                got error

                Creating group ‘developmenttest2'on the server …

                  *** 404 not found

                 

                I have tried all the possible options, but could not succeed.

                 

                 

                Can you help me how to resolve this issue.

                 

                 

                • 5. Re: Tabcmd issue
                  Michael LaMont

                  I am also having the same issue as Srinivas. Any help would be greatly appreciated!

                  • 6. Re: Tabcmd issue
                    Jeff Strauss

                    are you using the x86 version of tabcmd or x64?  I tried it out local on my server and it's working here.  Also, are you using SSL?

                    • 7. Re: Tabcmd issue
                      Justin D'Cruze

                      Only thing I can think of is either:

                      • You don't have permissions to create groups (is the user being used to login a site/system admin??)
                      • Or some sort of weird glitch caused by a mismatch between the version of Tableau Server and the TabCMD install you're using

                       

                      If it's not either of those, I'd probably get Tableau Support involved....

                      1 of 1 people found this helpful
                      • 8. Re: Tabcmd issue
                        Srinivas K

                        We are running the tabcmd using 32 bit where as my server is 64 bit.  We assume this is causing the issue because when we tried to run using 64 bit tabcmd , the commnds are working fine.

                         

                        We are not sure whether is there any limitation such.

                         

                        Thanks All for your help!