2 Replies Latest reply on Aug 3, 2016 7:10 AM by Jeff Strauss

    Backup error with HA enviroment on Tableau 8.2.1

    Italo Maineti

      Hi,

       

      CASE:

      I have a weekend backup, that has been working without problems for about 1+ year.

      My enviroment have 2 servers, primary and worker, ALL components are duplicated between them, like repository, DataEngine, and so on...

      But this sunday (24/05) the backup returned the error below:

       

      IMPORTANT:

      I tried to run this same backup yestarday (27/05), without do anything and I had NO ERRORS.

       

      24/05 - ERROR:

      Command : tabadmin backup -t -d D:\TABLEAU_DUMP D:\TABLEAU_DUMP\TBSDMP

      ==== Using the backup tmp directory: D:\TABLEAU_DUMP (free space : 1:42 TB)

      ==== Setting enheritance from log http_requests older than 7 days - 8 Deleted rows

      ==== Backing up DataEngine extracts

      ==== Backing up database date

      *** Failed to set reap_extracts prevention During backup: The driver encountered the unknown error: An I / O error occurred while sending to the backend.

      *** Comand ' "D: / Program Files / Tableau / Tableau Server / 8.2 / pgsql / bin / pg_dump.exe " -h workgroup ' failed with code 1 , result was pg_dump : Error reading large object 1412796 : Server closed the connection unexpectedly This probably means the server terminated abnormally before or while processing the request.

       

      QUESTION:

      Anyone saw this error already? Know the causes?

       

      POSSIBLE CAUSE (?):

      I searched for "reap_extracts" and "An I / O error occurred while sending to the backend" and i foubd the 2 links below, i think that the error could be associated with repository replication:

       

      http://stackoverflow.com/questions/20878854/postgresql-exception-org-postgresql-util-psqlexception-an-i-o-error-occured-w

      http://www.postgresql.org/docs/9.1/static/runtime-config-replication.html

       

      Sorry for my bad english!!

        • 1. Re: Backup error with HA enviroment on Tableau 8.2.1
          Paul Banoub

          Hi - Was this ever solved? I'm currently experiencing this problem with V9.2.6

           

          Any more info appreciated

          • 2. Re: Backup error with HA enviroment on Tableau 8.2.1
            Jeff Strauss

            I did not see the original post, but came across it now.  Based on the original post it almost looks like there is a db lock on the pg_largeobject table and it couldn't access it.  What time do you run your backup?  We are on 9.2.6 with a H.A. distrubuted cluster and do not run into any issues with a nightly backup that starts at midnight.  And as part of the backup we do a quick tabadmin ziplogs, tabadmin stop, tabadmin cleanup, tabadmin start, tabadmin cleanup, then a tabadmin backup to make sure everything is clean in terms of logs, sessions, etc.  And it works like a charm.

             

            Also, do you have sufficient disk space for dumping the output?