2 Replies Latest reply on Mar 5, 2015 9:51 PM by Troy Miller

    Why is my text appearing as null?

    Troy Miller

      I update a public dashboard with public education data on a weekly basis.  When refreshing my extract some of my text is appearing as null for no apparent reason.  I'm using a non-pivot Excel spreadsheet for this extract.

       

      For example, a school's type (general education, alternative education, etc.) is appearing as null after working properly for some time.  After fixing this (moving data column), now other fields identifying a different school characteristic with a text string (School grade: A, B, C, D, F; Magnet status: magnet school, not a magnet school) are appearing as null after working properly for some time.  I moved the data column to the left and tried some other methods with the new fields showing null values, but nothing has worked.

       

      So there are two issues I'd greatly appreciate some help with... 1. why might my text string appearing as null in the first place and 2. why is it following a workbook update are properly functioning text fields changing to null values?

       

      Many thanks in advance...

       

      My dashboard on Tableau Public: Workbook: Florida FAFSA Finish Line

        • 1. Re: Why is my text appearing as null?
          Shine Pulikathara

          I wonder if this has anything to do with the Microsoft Jet Database Engine. You can read more here: Resolving Incorrect Data Type Issues | Tableau Software

           

          Some specific symptoms that suggest misinterpreted data types include:

          • A field that should display as a dimension appears as a measure.
          • A field that should be a string, such as ID, is interpreted as a numeric field (or vice-versa).
          • Numbers are interpreted as dates, are rounded incorrectly, and so on.
          • Unexpected null values.

           

          Great looking dashboard, by the way!

          1 of 1 people found this helpful
          • 2. Re: Why is my text appearing as null?
            Troy Miller

            After reading up on link you provided for resolving incorrect data type issues, it appears as though that is the culprit, but I'm not clear on how I fix my issue.

             

            My workbook is saved in Tableau Desktop 8.2 and my Excel spreadsheet is saved in .xlsx format (Excel 2013).

             

            I created the workbook around the end of 2014/start of 2015, which could have been Tableau 8.1... I'm not sure.  If I start my workbook from scratch in 8.2, am I correct in concluding the issue with the Microsoft Jet Database Engine will be resolved?  The troubleshoot says to update my Excel file, but I'm not sure what that means given that I'm using the most recent version available (.xlsx),