2 Replies Latest reply on Feb 27, 2015 3:24 PM by James Profitt

    waiting wgserver process on worker

    vikram bandarupalli

      Hi Guys,

       

      I encountered an issue will installing a new instance of tableau cluster and i haven't see it before. Wondering if anyone in the server community has seen and resolved it.

       

      I'm installing a cluster environment and adding a worker to host Application server process(wgserver). If i have the wgserver on primary, i'm able to start the cluster. However, if i add application server on worker, i get an error when starting the cluster.

       

      Error message:

      :\Program Files\Tableau\Tableau Server\8.3\bin>tabadmin start

      ==== Starting service...

      Tableau Server not available; check that it is running.

      ==== Service failed to start properly. Run "tabadmin status -v" and see "tabadm

      in.log" for more details

       

      From the tabadmin log file, i see that

      ----------------------

      Waiting for wgserver on 8000 to become ready by requesting http://IP Address of worker/wg/auth/system_status...

      Gave up on with_rails_ready, Tableau Server not available; check that it is running.

      3LL32LFHIQN_:_pid=6196_0x3c38c22b__user=__request=__ Tableau Server not available; check that it is running.

      2015-02-25 19:53:36.802 +0000_INFO_ac12:775:0:0:8a1:c417:80fa:ffff:WIN-3LL32LFHIQN_:_pid=6196_0x3c38c22b__user=__request=__ Service failed to start properly. Run "tabadmin status -v" and see "tabadmin.log" for more details

      ---------------------------------

       

      The status of all the processes shows "running".

       

      Any inputs why adding a application server to worker is able to start tableau server?

       

      Vikram

        • 1. Re: waiting wgserver process on worker
          James Profitt

          Hi,

           

          I too am receiving the same error during startup. However, during testing, I found that the issue was fixed once the firewall was disabled. Haven't had chance to narrow it down yet. Will let you know if I find anything useful.

           

          Thanks

          • 2. Re: waiting wgserver process on worker
            James Profitt

            I think there are a couple of things happening here:

             

            1) During startup, the primary issues this request to all of your WGServer instances: http://ServerName:8000/wg/auth/server_status. If the server does not respond, it retries, and then continues until a preset threshold. After this threshold, you get the error mentioned. I think the "with_rails_ready" text is an internal identifier of some kind, not terribly relevant to the issue at hand.

             

            2) The WGServer may actually start running (and reporting its status) after this threshold if the server performance is not great - the test server I'm using is pretty slow, and so the primary thinks the stuff is not working.

             

            3) Use "tabadmin status -v" to check if everything is up and running.

             

            4) During my testing, I found that the main Admin page would actually report my worker servers as being down, even though the status command above reported them as running. Eventually, I found this was because some Inbound firewall rules were not present on the worker, and the connections were being refused. I needed to add a rule for all server types I had deployed. After this, they were reported to be OK.

             

            Note that in order to find when the Windows firewall is blocking an application, you need to enable certain Auditing options in the Local Group Policy applet (gpedit.msc). Then it starts to report Events which you can find with the event log (Event ID = 2011, assuming you don't have notifications turned on).

             

            I tried configuring the firewall to write out to a file that I could parse, but to no avail.

             

            Some useful sites:

             

            http://www.telerik.com/download/fiddler

            https://technet.microsoft.com/en-us/library/dd421717%28v=ws.10%29.aspx

            https://technet.microsoft.com/en-us/library/ff428143%28v=ws.10%29.aspx

             

            I mention fiddler because I used it to see the http requests that the main site was issuing.

             

            Hope this helps.

            1 of 1 people found this helpful