1 Reply Latest reply on Jan 16, 2015 12:22 PM by diego.medrano

    Data Blending issue with * for the tableau extracts??

    indy poo

      Hi,

       

      I am facing an issues while blending of 2 tableau source extracts( not the normal sources), the both  sources are extracts.After the blending i am getting the no of counts as ( *), asteric sign becuase , the counts are more than 1 , because it has  1:m relationship.

       

      But unfortunately we do not have any control on the source, we are receiving the sources as Tableau Extract format only , to apply the joins in the source level  and avoid the (*) sign 1: m relationship.

       

      Is there any way in the tableau interface level \any tableau function to avoid the (*) mark for the one to many (1:m) relationship for the tableau source extracts in the tableau interface level?

       

      I just tried with some tableau calculation, computation approach , but still its not working.

       

      If some one knows about this please let me know.

       

      Attached is my tableau package.

       

      Regards,

      Indy

        • 1. Re: Data Blending issue with * for the tableau extracts??

          Hey Indy,

           

          I believe the issue you are experiencing is because userformsubmission_extract should be the primary data source. The information below should also help in creating one-to-many relationships in Tableau:

           

          Option 1: Aggregate Extracts

          1. Hide the duplicating field (Product Name) from the Data pane:  Right Click  > Hide.
          2. Change the default aggregation of Sales to MIN:  Right Click > Field Properties > Aggregation.
          3. Right Click data connection and select Extract.
          4. Check the box Aggregate data for visible dimensions.
          5. Click Extract.

          Option 2: Data Blending

          1. Connect to each table separately.
          2. Establish a relationship at the level needed to blend and not at the duplicating field level: Data > Edit Relationships.
          3. Build visualization while omitting the lowest level of detail that is causing the duplication.

          Option 3: Custom SQL

          1. Write a sub query that contains measure to sum and the field that is one step higher than the duplicating field.
          2. GROUP BY that field.
          3. Insert that new measure into the select statement.
          4. Build  visualization with the new measure instead of the old one.

           

          I hope this helps!

           

          Diego