6 Replies Latest reply on Jan 27, 2014 1:26 AM by chris.shaw

    Redshift errors

    Imran Akbar

      I'm using Tableau 8.1 inside VMware Fusion on Windows 8.

      Connecting to Amazon Redshift with the Redshift connector, I managed to connect ok but keep getting errors anytime I try to add a new table to the data, or drag any dimensions or measures over to the right side side to a row/column/filter.  I basically can't create any workbooks because of this.

       

      "An error occurred while communicating with the data source tlog_tlogbasket (public.tlog_tlogbasket) + (tlog)"

      the details are:

      ERROR: current transaction is aborted, commands ignored until end of transaction block;

      Error while executing the query

      The table [public].[tlog_tlogbasketitem] does not exist.

      Unable to connect to the server [*].us-west-2.redshift.amazonaws.com. Check that the server is running and that you have access privileges to the requested database."

       

      I've also tried grabbing an extract, but I have the same issue.

       

      How is it that I can connect to the Redshift cluster, get the schema and a list of all the tables, but subsequent queries don't work?

       

      thanks,

      imran

        • 1. Re: Redshift errors
          Imran Akbar

          The errors disappeared once I refreshed the connection yesterday, but now they're back again.

          I know the table does actually exist because I can see data from it in another software package.

          I've tried the PostgreSQL driver as well, but I still get the same errors.

          Any suggestions?

           

          thanks

          • 2. Re: Redshift errors
            Andrew Rickard

            I'm having a similar issue when using Tableau v8.1 and connecting to a multi-node instance of Amazon redshift. Seems to be problems with accessing the right schemas. I switched back to v8.0.1 and the problem doesn't occur.

             

            -Andrew

            • 3. Re: Redshift errors
              Nermin Softić

              I'm still having the same problem. I've tried with v8.1.0,   v8.1.2 and v8.0.1 but no progress. I thought it was because my tables were in the public schema so I created a second schema but then I had different behavior from each version where the v 8.1.0 didn't even see my tables but v8.0.1 did see them but I had the same error again.

              Could it have anything to do with the fact that my client is 32bit.

              • 4. Re: Redshift errors
                Andrew Rickard

                The only way I've found to workaround the problem was to supply Tableau with the custom SQL necessary to access the data. Using single or multiple tables just doesn't work with Tableau properly at the moment.

                 

                -Andrew

                • 5. Re: Redshift errors
                  Ashley Jaschke

                  Hi all,

                   

                  Upgrading to the latest maintenance release 8.1.3 (or 8.0.7) should resolve these issues.  Please feel free to email me directly if you upgrade and are still having issues.

                   

                  Ashley Jaschke

                  Product Manager, Tableau Software

                  • 6. Re: Redshift errors
                    chris.shaw

                    We're experiencing this on v8.1; With a custom SQL query the connection keeps terminating.

                     

                    No issues on v8.0.

                     

                    I've raised a support query so will update here if we find anything out.