5 Replies Latest reply on Aug 1, 2013 10:50 AM by Matt Lutton

    export icon missing

    Karl Jensen

      I have just started using the &:tabs=no option in my URL so that users don't see the tabs at the top of the browser.  I do this so that they use the filter actions that take them to the next dashboard page (passing the filters they have selected).  This works great, but I have noticed that the export icon only appears on the first page.  Has anyone else done this?  Is there a work around or a way that I can get them to appear on each dashboard page?

       

      Thanks,

      Karl

        • 1. Re: export icon missing
          Matt Lutton

          It must be a permission--as I just tested this and I see the export option on every sheet in the workbook.  Make sure permissions are passed on to all contents of workbooks... Setting Permissions for Workbooks and Views

          • 2. Re: export icon missing
            Karl Jensen

            It is only there for me on each dashboard page IF I allow the tabs to be displayed.  I even just tried it in FireFox (as opposed to IE).  If I include the &:tabs=no in my URL, then I only see these on the first tab.  I wonder what security thing I could be missing....  I can't think of a place where you tell it information about where to place the icons.

             

            I did learn the other day that I can move them from the bottom to the top by changing the embed=y (puts it at the bottom) to embed=n (puts it at the top).  The problem I have is if you don't embed the report, then the end user gets the option at the top to go "back" into the Tableau Server.  To keep the users from getting confused, I don't want them to go into the Server.

             

            There is probably a fundamental thing I am missing around displaying the menu bar for exporting, sharing, etc.  Any guidance I would appreciate.

            • 3. Re: export icon missing
              Matt Lutton

              There is a permission setting for users/groups/projects that will either allow exporting or not.  I am assuming the permission is set to Deny for contents of the workbook.  Sometimes folks apply permissions to workbooks, but not the sheets inside the workbook.  That is why I linked the permissions document, as it discusses how to ensure permissions are set correctly for all sheets and at all levels.  It can be confusing, I will admit that.

               

              As I said, I tested several of my own workbooks, and the export button was always there for me.  If you don't use the embed parameters, do you see the export button on all the sheets?  If so, I'm not sure I am much help as the parameters in the URL should not impact whether or not this button displays, as far as I know.

              1 of 1 people found this helpful
              • 4. Re: export icon missing
                Karl Jensen

                Interesting.  when I look at the individual dashboard pages, they are set to the same permissions as the entire workbook (which is how I understood it to work - it inherits from the higher level unless you specify something different).  This is how my permissions are set within each dashboard page (and the entire workbook).

                 

                Permissions.jpg
                The fact that you don't have this problem tells me I am still doing something wrong.

                 

                Great suggestion on the setting embed=n, it always shows them at the top for this.  I might use this as a work-around until I find out what I am doing wrong.

                • 5. Re: export icon missing
                  Matt Lutton

                  Hmm, I'm not sure what else to check; I just assumed it was a permissions issue as that can be confusing but you seem to understand this and I'm not sure why you don't see the export option on the other sheets.