6 Replies Latest reply on May 12, 2013 11:05 PM by Anisha Nair

    Tableau 8.0 - Titles and Caption

    Anisha Nair

      Is the title space also allotting space for Caption on Tableau 8.0??


      In the Screenshot 1 below, the Filter Summary section is basically a worksheet TITLE which displays all the filters that is chosen on the dashboard. As seen, there is an empty space on the right which is automatically being allotted to Caption, which I DON'T require. Due to this text wrapping, the filter summary is overlapping the Fiscal Year End filter below when the view is exported to an image (Screenshot 2 on right). Is there any way to turn the Caption area off? Of course I can probably fix this issue by increasing the vertical space for the Filter Summary section. But the empty space on right looks really clumsy!!

      Screenshot 1                                                     Screenshot 2

      Capture.PNG                         Capture2.PNG

        • 1. Tableau 8.0 - Titles and Caption
          Shawn Wallwork

          To turn off the caption on a dashboard click the little triangle in the upper right corner of the sheet and un-check Caption:


          Caption off.png


          Hope this helps.



          • 2. Re: Tableau 8.0 - Titles and Caption
            Anisha Nair

            Thanks for your reply...


            I am not sure anymore if it's the caption that causing the white space...my captions are turned off, but the white space is visible...I have attached a sample workbook...if you see the filter summary section, there is white space on the right...is there any way i can remove it? I don't understand why that space is reserved...

            • 3. Re: Tableau 8.0 - Titles and Caption
              Shawn Wallwork

              Anisha, I was pretty sure it wasn't the caption. Thanks for the workbook, but you'll need to post a packaged workbook (twbx). The one you posted (twb) doesn't have any data in it.



              • 4. Re: Tableau 8.0 - Titles and Caption
                Anisha Nair

                oops! Here is the twbx one

                • 5. Re: Tableau 8.0 - Titles and Caption
                  Shawn Wallwork

                  Good news: This can be fixed. Bad news: it takes a bit of work, and several workarounds.


                  [Note: All this could be avoided if the Text Object allowed any and all fields, filters and parameters in the dashboard to be inserted. I thought I created an Idea for this, but I can't find it now. If anyone knows where it is please post a link. Thanks.]


                  Let's get started, first you should know that the size of the sheet on the worksheet page affects the display on the dashboard. If you drag the right border of the ABC part of the viz to the right then the title on the dashboard will fill out, getting rid of the white space, but there's a better way to fix the problem, namely "Fit Width". I only mention it because Maps do not have any of the Fit options, so if you do maps you'll need to resize the worksheet to get them to fit (but that's a whole different topic).


                  Here are the steps I did to produce the attached workbook:


                  Click the little triangle in upper right of the that worksheet on the dashboard and click fit, fit width



                  This will give you this:




                  Now we have to fix the highlighted part. Go to the sheet, create a calculated field named "Blank" that contains " " and put it on the label shelf, like this:




                  This will get rid of the ABC's. [Note: there are other strategies for doing this detailed here http://kb.tableausoftware.com/articles/knowledgebase/removing-abc-placeholders


                  Now your worksheet should look like this (without the two arrows of course ):



                  We still have the two problems, while borders are set to None by default, Tableau's "None" really means light-blue. [I think there's an Idea posted somewhere to change this.] The other problem is since your data won't all fit on the sheet T puts in a usually helpful "..." but since you're just using this sheet for it's title we don't want to see it, so we'll need to fix that.


                  First we'll do the borders. Right-click the cell and click format. Then click the border icon:




                  See how there are light-blue lines in all the pull downs below the default section, some of those are what is creating the border. When you change all the Defaults from None to White you'll get rid of all the header borders:




                  Then when you change the Row/Column Panes to white you get rid of the rest of the borders:





                  The only way I found to get rid of the ellipses was to squeeze the height of the viz down to the minimum, which hides them. (See attached).


                  I spelled all this out in detail, so if new folks find this thread, they'll have a step-by-step set of instructions. I'm sure you already knew most of this.


                  Good Luck.



                  • 6. Re: Tableau 8.0 - Titles and Caption
                    Anisha Nair

                    Thanks so much Shawn!


                    I can't believe I didn't try the "Fit Width" option...