4 Replies Latest reply on Aug 12, 2015 8:31 AM by Xriss Fab

    TABCMD - Uncaught Exception: Unable to load jvm.dll

    Aaron Anzalone

      I installed the tabcmd utility on a new server Win2008R2 and any time I try to run tabcmd, I get the following error: Uncaught Exception: Unable to load jvm.dll. How do I resole this issue?

        • 1. Re: TABCMD - Uncaught Exception: Unable to load jvm.dll
          Russell Christopher

          Morning Aaron --

           

          What version of Tableau Server did this come from? Does a re-install make a difference?

           

          While I'm not in Support, I took a quick look at our old cases and don't see anyone else running into this.

           

          I DID see an old, old bug where someone saw a similar error message doing something completely different, and the problem had to do with not having Microsoft's C++ redist installed on the machine. This is a complete shot in the dark, but I wonder if your issue is related since you're on a relatively new machine?

           

          Try this and if it doesn't work, I'd probably open up a case with Tech Support:

           

          1. Uninstall TabCmd
          2. Re-install TabCmd and note the folder it is being installed into (for example, C:\Program Files (x86)\Tableau\Tableau Server\7.0\extras)
          3. DON'T click Finish in the Installer. Browse to the folder where you're currently installing. You should see a folder named "Install" along with "Command Line Utility" and and "repository".
          4. Open the Install folder and grab vcredist_x86.exe - copy it somewhere else.
          5. Click Finish in the TabCmd installer to let it complete
          6. Install the vcredist_x86.exe file yourself.
          7. Try TabCmd

           

          I'm totally swinging for the fences on this one, but it'll only take you a minute to see if my longshot guess was right.

          2 of 2 people found this helpful
          • 2. Re: TABCMD - Uncaught Exception: Unable to load jvm.dll
            Jeff Dickson

            Were you able to find a solution for this?  I am running into the same problem.  jvm.dll is a file included in the Java JDK, which I have installed.  I'm running 64-bit Windows, and I've tried both 64-bit and 32-bit Java with no success.  I also tried Russell's suggestion with no luck.  Any other ideas?

             

            EDIT:

            I've got it working.  I tried several different things and I'm not completely sure which one worked, so I'll post them all here in case anyone else needs the help.

             

            1. After installing tabcmd, I opened PowerShell and executed it with no arguments just to see if it worked.  I got the error "Uncaught exception: Unable to load jvm.dll"
            2. I knew that jvm.dll was part of Java, so I installed the 64-bit Java JDK, available here: http://www.oracle.com/technetwork/java/javase/downloads/index.html
            3. I still got the same error.  I then tried the suggestion from Russell (copy vcredist_x86 and install separately).
            4. I still got the error.  I decided to try using Command Prompt instead of PowerShell since they work a little bit differently, and I got a completely different error: "The program can't start because MSVCR71.dll is missing from your computer."
            5. Sure enough, MSVCR71.dll was not present under C:\Windows\SysWOW64\.  I downloaded a copy (see http://www.addictivetips.com/windows-tips/fix-msvcp71-dll-and-msvcr71-dll-missing-error-in-windows-7/), put it into the SysWOW64 folder (put in System32 if you're running 32-bit Windows), and tabcmd was working after that.

             

            Good luck!

            • 3. Re: TABCMD - Uncaught Exception: Unable to load jvm.dll
              Jason Phipps

              We had a similar problem when upgrading to Tableau Server 9.0.

              The install process would abort with the error message "Unable to load jvm.dll".

              Through a long and arduous process we finally figured out that bother versions (32 bit and 64 bit) of MSVCR100.dll were corrupted. Installed the most recent Java version and copied the two versions into C:\Windows\System32 (64 bit version) and C:\Windows\SysWOW (32 bit version).

               

              Hope this info helps somebody.

              Wolf Metzner

              • 4. Re: TABCMD - Uncaught Exception: Unable to load jvm.dll
                Xriss Fab

                Maybe I am a bit late but I have an alternative solution. U can also load this file from http://fix4dll.com/msvcr71_dll and put it to the needed folder. It's done. Simple solution.