2 Replies Latest reply on Sep 20, 2012 10:44 AM by Jeff Austin

    Stop line graph from showing "missing data"

    Jeff Austin

      I'm using Tableau Desktop Pro ver 7.0.1 on Windows XP SP3. How do I get my line graph to not plot missing data?  I've checked the help which states that the default behavior is to not display missing data.  Moreover, when I check the "Show Missing Values" option on my date container used for the chart columns, "Show Missing Values" it is not selected.  I tried selecting a missing data point and looked for an option to exclude that one data point, but that option isn't available like it is for a data point with an associated value.  I've attached a screen shot where, for example, I want the Oct 2011 - Apr 2012 gold line gone.  Thanks in advance for any help provided - Jeff.

        • 1. Re: Stop line graph from showing "missing data"
          Mark Holtz

          Hi Jeff,

           

          Because other dimensions for your lines (the non-yellow and non-cyan colors) have data in that position, I don't think you're interested in the "show missing values" on the axis.

           

          I think you're after Null handling. 

          Right when the graph is created, it usually defaults to say "n Null values" and you can click on that and choose to "Show Null Values at default/0" or something like that. As a habit of "cleaning up" things like that, I almost always choose to show them right away to make that little pop-up go away.

           

          You can modify "Special Value" (Null) handling at the bottom of the Format window for the Measure.

           

          If that doesn't get rid of the lines down at 0, then you might actually have 0 values in your underlying data.

          If that's that case, you could potentially create a calculated field to force nulls in place of 0's... (CAUTION as this may impact more records than you intend):

          IF [MeasureField] = 0 THEN Null ELSE [MeasureField] END

           

          nulls.png

           

          Hope this is helpful!

          • 2. Re: Stop line graph from showing "missing data"
            Jeff Austin

            Using the Format option for handling speciaI values was the solution.  Thank you.  For the benefit of others who come across this, here are the steps as it was not readily clear to me:

            - right click on the measure

            - choose Format from the pop up menu

            - click the Fields drop down list near the top right of the Format pane

            - select the field being plotted by the line graph

            - click the Pane tab on the Format pane

            - under the "Special Values (eg. NULL)" section of the Pane tab on the Format pane, set Marks to "Hide (Break Lines)"

             

            It has been my experience in working with projects created in version 7.0.1. that this is the default for displaying NULL values.  The help documentation states this is the default.  However, this project I'm working on was created with version 6.1.  So, it may the the conversion to the 7.0.1 format that is causing it to behave differenlty.  Thanks for the help!

            1 of 1 people found this helpful