10 Replies Latest reply on May 2, 2016 2:52 PM by Adam Montague

    Maps showing scroll bars

    Gourav Kumar

      Dear All,

       

      I am having trouble showing maps in a dashboard.

       

      When ever I reduce the size of the displayed maps too much scroll bars appear. These are not looking neat.

       

      Can we remove the scroll bars in anyway?

       

      Increasing the size of the display or visual to remove these scroll bars is not an option for now.

       

      I have attached a file for reference.

        • 1. Re: Maps showing scroll bars
          Shawn Wallwork

          Gourav,

           

          You've hit on one of the more frustrating areas of Tableau. In fact I tried putting together an 11 map dashboard during the 30 day trial, and we almost didn't buy Tableau because this was so difficult to do. Anyway here's the best I could come up with (without spending a lot of time):

           

          Map Size Overall.png

           

          The trick to getting rid of the sliders is to go to the sheet and make the map small there:

          Map Size-1.png

          Then when you come back to the dashboard you'll get this:

          Map Size-2.png

          Now you grab the edge of the map and carefully work it to the right & down a little at a time. If you go too far the sliders will pop. Just hit the back button and start over. Eventually you can get pretty good at it. Just don't get too greedy. And realize you're not going to get all the maps spaced perfectly (unless you have the patience of a Zen Master).

           

          Why Tableau doesn't allow 'fit entire view' with maps, like they do with other chart types, I don't know. You'll have to ask them

           

          Couple of other notes:

          • I got rid of most of the containers you had on the dashboard; they just make sizing the maps more difficult
          • Instead of using the containers to create borders, I used the map's borders. To my eye it looks better, because you can border the title too, without getting a double border
          • You might consider getting rid of the titles for each map and putting that info on the map itself using annotations. It'll give a cleaner look, and more room for the map
          • I never could find a good place for the Total IP box, but sometimes that's just the way it is.

           

          Good luck, and remember patience grasshopper, patience.

           

          --Shawn

           

          EDIT: Just noticed something odd, well good odd. If you look closely at the image above you'll see that the 'About Tableamaps...' watermark is only on two of the maps! Keeping the watermark from displaying on every single map is a feature request many (OK some) of us have requested many times. Could Tableau be working toward fulfilling this request? That would be great!

          • 2. Re: Maps showing scroll bars
            Gourav Kumar

            Oh, Thanks a lot for your answer, I will try it and share with my team. Hope to achieve this.

             

            Thanks for spending such a lot of time on this visual. Appreciate it a lot.

             

            By the way it is really frustating.Dashboards is one of the area's Tableau could improve a lot. You can not change filters fonts. There sorting. Annotations are so clumsy. Plus as soon as you put 7-8 sheets on a dashboard its gets so slow.

             

            ** On your point of having no watermark, I have just used the offline maps option. In one of them the backgroud was disappearing that's why kept it. On second thoughts I will just use an image to avoid the watermark altogether as the maps will not change.

             

            Map1.PNG

            • 3. Re: Maps showing scroll bars
              Shawn Wallwork

              Gourav,

               

              If you use a background image, you will then gain the use of fit 'Entire Image' and you avoid the jiggering mess altogether.

               

              --Shawn

              1 of 1 people found this helpful
              • 4. Re: Maps showing scroll bars
                Gourav Kumar

                True. If we dont have changing maps we can use images and this will do away with the messy scroll bars.

                • 5. Re: Maps showing scroll bars
                  Michael Carper

                  I ran into this problem and solved it by just deleting and re-adding the sheet to the dashboard.

                  • 6. Re: Maps showing scroll bars
                    Shawn Wallwork

                    Michael, welcome to the forums! You are correct there are many new features in V8 that make this V7 problem easy to overcome. Floating containers make my 11 map dashboard extremely easy to layout -- with pixel precision! Floating objects and those wonderful Position/Size controls are by far my two favorite new features in V8. (Thanks for these T!)

                    Controls.png

                     

                    --Shawn

                    • 7. Re: Maps showing scroll bars
                      John Sobczak

                      Wow Shawn, I was just having the same issue with map scroll bars and found this solution very useful!  This caused me a lot of frustration a few days ago and again today.  I should have known to look here right away!  I can't believe it is not fixed 2 years and a few releases later!

                      • 8. Re: Maps showing scroll bars
                        John Sobczak

                        Shawn,

                         

                        I wanted to circle back on this.  It seems this solution provides partial relief when dashboard view window is maximized to complete screen.  When the dashboard window gets resized in windows or browser, the scroll bars re-appear.  For some reason the default worksheet view equilibrium state is destroyed once one gets in this state.  I found it best to recreate the entire worksheet from scratch as per Michael's post to avoid any future issues as painful as that might be.  I don't know if you have discovered anything new on this since this post such as if there is a way to get back to default state without having to recreate the entire worksheet.

                        • 9. Re: Maps showing scroll bars
                          Mihai Badicioiu

                          Hello Guys,

                          I got this simple trick:

                           

                          Click on the worksheet - map in some map area and choose === Clear Manual Sizing.

                               Tableau takes over and get's rid of the scroll bars + automatically sizes the map.

                           

                          Works great for me in Tableau 8.2.

                          2 of 2 people found this helpful
                          • 10. Re: Maps showing scroll bars
                            Adam Montague

                            So simple, and it works perfectly.

                             

                            Thank you!