7 Replies Latest reply on Mar 28, 2013 1:58 PM by Sean Mullane

    Powerpivot error: "Sandbox cube..."

    . Agustarson

      I've started using PowerPivot 2012 with Tableau. While I haven't run into any problems with most of the files I've created so far, there is one recent error that has come up.

       

      I extracted around a million rows from an SSAS cube into Powerpivot. Only a dozen columns or so. The resulting Excel file is only 30+MB. When I connect to it in Tableau, which happens error-free, it's only when I try to view a measure or drag in a dimension that I get the following error message:

       

      "The Sandbox cube either does not exist or has not been processed."

       

      Has anyone seen this before?

       

      I'm using Tableau 7.0, Excel 2012, PowerPivot Tableau Add-In for 7.0 and PowerPivot 2012.

        • 1. Re: Powerpivot error: "Sandbox cube..."
          Russell Christopher

          The "Sandbox" cube is what Microsoft names the xVelocity database they embed in your workbook when you do your import. The only time I've ever heard of someone seeing this message is when they try to connect to a PowerPivot workbook out on SharePoint *AND* the workbook's "cube" is in the process of being re-processed.

           

          Was this PowerPivot workbook created with the same instance/version of Excel/PowerPivot as the others that actually work? I don't think our Tableau 7.0 Add-in works with the updated version of PowerPivot (2012) that was released a few months ago - that might be your problem. I seem to recall we failed with a different error message against a PowerPivot 2012 xVelocity database, though.

           

          To confirm, I'd try a couple tests:

           

          • Create a new PowerPivot workbook with your 2012 Add-In and import any old data (not SSAS). See if it fails w/ Tableau
          • Uninstall the PowerPivot 2012 add-in and install PowerPivot 2008 R2 Add-in instead. Import your cube and see if we can connect to that workbook....

           

          Let us know what you find. I'm curious!

          • 2. Re: Powerpivot error: "Sandbox cube..."

            Coincidentally I ran into this same exact problem today.

             

            I am using Excel 2010, PowerPivot 2012, and Tableau 7.0 with the "Tableau 6.1 Add-In for PowerPivot Excel (32-bit)" driver.  I do not have SharePoint installed and thus I am unable to generate a PowerPivot cube.

             

            In Tableau I create a connection to Microsoft PowerPivot.  In the dialog box that follows I select "Local Excel File", browse to the file, and click Connect.  After a few seconds I'm able to make a successfull connection to the "database".  However, when my new Tableau workbook opens and I drag a dimension or measure onto the canvas, I get an error that reads: "An error occurred while communicating with data source 'POC.xlsx (Microsoft PowerPivot)'."  If I click the Show Details button the message reads "The Sandbox cube either does not exist or has not been processed."

             

            I then uninstalled PowerPivot 2012 and installed PowerPivot 2008 R2.  I created a small PowerPivot model to test with and connected to it using the same steps as I described above.  My sample PowerPivot model worked perfectly in Tableau.  However, when I attempt to connect Tableau to my original PowerPivot model - or even open it in Excel for that matter - I get an error that reads "You are attempting to access PowerPivot data that was added using a newer version of PowerPivot. This action is not supported, and you cannot access the data. To continue working with the PowerPivot data, you must use the latest version of PowerPivot."  That's a Microsoft error and of course that makes sense, I can't use an earlier version of PowerPivot to open a model created in a later version.

             

            But now I'm faced with either recreating my ENTIRE PowerPivot model in PowerPivot 2008 R2 (and losing all of the added functionality that comes with 2012) or copying ALL of my PowerPivot data into Excel and use that as a source for Tableau.  Very frusterating.  Any chance this can get fixed?

            • 3. Re: Powerpivot error: "Sandbox cube..."
              . Agustarson

              Thanks Russel, going back to 2008 worked. I actually had removed 2012 and installed 2008, but coincidentally had run into a different error with a workbook I used that seems unrelated although I had assumed otherwise. I built the powerpivot model again using 2008. I was able to run the prior Powerpivot model in a virtual Win7 and copy the column formulas over to the new model, so it didn't take too long.

               

              My vote for supporting 2012, when going back to 2008 I can really appreciate the subtle changes Microsoft has made to Powerpivot.

              • 4. Re: Powerpivot error: "Sandbox cube..."
                Russell Christopher

                Hey Melinda -

                 

                Yes, the dev team is aware of this and I'm sure we'll see an update - Can't tell you exactly when, though.

                • 5. Re: Powerpivot error: "Sandbox cube..."
                  Sean Mullane

                  Hey Russell,

                   

                  Have there been any updates on this? I'm very interested in how Tableau 8 interacts with SSAS 2012, especially the Tabular model.

                  • 6. Re: Powerpivot error: "Sandbox cube..."
                    Russell Christopher

                    Sean - Tableau has been working correctly with the latest/greatest version of PowerPivot for some time now.

                     

                    You also can connect to a 2012 Tableau Data Model, although we don't officially support doing so. There are a few things that don't work, like creating DAX expressions (we simply see DAX as "bad MDX") and occasionally you'll need to "up" the Solve Order on MDX expression that you write as calculated members.

                     

                    Above and beyond that, it pretty much is the same as SSAS.

                    • 7. Re: Powerpivot error: "Sandbox cube..."
                      Sean Mullane

                      Thanks for the info, Russell.