4 Replies Latest reply on Aug 9, 2012 11:27 AM by Gabriel Gejman

    filter: wrong default value - impersonate authentication

    Daan Vloedgraven

      Hello, 

       

      I have a problem with the default value of a filter when an end user opens a view on tableau server.

       

      situation: the datasource is a direct connection to sql server and we use impersonate authentication. (we don't use ‘user filters’)

       

      Our goal is to authorize an user (person demoschool) for the data of his own department (08XL). We do this with a sql view with a
      where-statement on username. This works! Someone higher in the organization hierarchy (person demobestuur) needs the ability to choose between the departments (08XL, 03ON, 03RX, etcetera). This works too.

       

      The problem comes with the default value of the filter. I have two problems when demoschool opens the view:

       

      • it starts with ‘(03ON)’. This is because I selected this department when the workbook was published to the server. It places the
        organization between () because demoschool can only see the data of 08XL.:
      • it starts with an empty view, because demoschool has no rights for the data of 03ON. I don’t want to
        start with an empty view.

       

      Of course, when I select 08XL, it works.

       

       

      I have a work around, but I am really not happy with it: in desktop, ‘show all value’, select all and publish. When demoschool opens the dashboard, it starts with all and I see data in my dashboard.

       

      I have to problems with this work around:

       

      • I don’t want the all option, because I want only a single selection. When demobestuur opens the view, all means more than one selection.
      • Whe demoschool export the dashboard, no one can see which department is selected, because it shows ‘all’. When there is only one
        selection, and the all option is available, it always show the all value.

       

      thanks for your help!

       

      p.s. in the attachment you find my printscreens