4 Replies Latest reply on May 23, 2012 7:02 AM by Ricardo Mota

    Import Custom Geocoding Portugal

    Ricardo Mota

      Hello

       

      I already read a lot of treads regarding this subject but I can´t import my custom geocoding csv file.

       

      I have this error message.

       

      Error.png

       

      I have change my settings to:

       

      Regional Def.png

       

      and create schema.ini according csv file. (Attached)

       

       

      [GeoPC_PTv6_demo.csv]

      ColNameHeader=True

      Format=CSVDelimited

      Col1="ID" Text

      Col2="Country (Abbreviation)" Text

      Col3="State (Name)" Text

      Col4="Concelho" Text

      Col5="Código Postal" Text

      Col6="Cidade" Text

      Col7="Freguesia" Text

      Col8="Latitude" Double

      Col9="Longitude" Double

       

       

      Did someone have a idea what could be the problem?

       

      Thanks

       

      RFM

        • 1. Re: Import Custom Geocoding Portugal
          Tracy Rodgers

          Hi Ricardo,

           

          Often the above error message occurs when the file that is being imported is opened. Close the file and try re-importing it. I have also attached the ini file and csv file here. Make sure that they are saved in a folder all by themselves. Hope this helps!

           

          -Tracy

          1 of 1 people found this helpful
          • 2. Re: Import Custom Geocoding Portugal
            Ricardo Mota

            Hello Tracy

             

            Thank you for your answer.

             

            The file is closed and the ini file is in the same folder.

             

            I have tried a thousand different situations and nothing. I had read all the posts in the forum and tried everything.

             

            I will keep trying!

             

            Thanks once again

             

            RFM

            • 3. Re: Import Custom Geocoding Portugal
              Richard Leeke

              I just tried to open your original CSV file in Excel and I got a weird message about Sylk file format not being supported.

               

              This turns out to be because the first two characters in the file are "ID", as described here.

               

              Not sure if this is what's confusing the custom geocoding import - I didn't look any further - but I thought I'd point this out. I notice Tracy has swapped the order of the columns in the file she attached, which would have been enough to get around the Sylk issue anyway.

              • 4. Re: Import Custom Geocoding Portugal
                Ricardo Mota

                Hi Richard

                 

                Thanks. I have saw this to. It's just changing "ID" to "Id". But these are not the problem.

                 

                I have found a solution with support team that I want to share:

                 

                1. Replace all the comma column delimiters in the file with vertical bar
                2. In the schema.ini file put this option: Format=Delimited(|) (Attched my schema.ini file and a csv sample)
                3. Put the csv file and the ini in the same directory
                4. Import in Tableau

                 

                 

                With this solution I was able to import.

                 

                 

                Normal Problems that I Found:

                 

                Decimal Separator: , or ; or . (This depends your regional settings that can be changed in Control Panel) I have imported mine with ,

                 

                I hope that helps

                 

                Thank you