1 Reply Latest reply on May 15, 2012 10:41 AM by Tracy Rodgers

    Parameter Control Affects Ranking Order

    Emma Whyte

      Hello,


      I am working with data that includes satisfaction scores for Speakers at events. The event attendees are scoring the speakers on a 1-7 scale.  Our client would like to rank speakers on their average (mean) scores. We have also developed a Z Score system to do this. (The Z Score is the Speakers standard deviation from the mean). We need to be able to filter out one speaker at a time to compare to all the other speakers.


      To accomplish this I have created a [Z Score] calculated field, a parameter [Display] from a list of values from [Speaker Name], and two calculations which control the parameter [Speaker Show] and [Speaker Hide].

       

      I then created two sheets, one with [Speaker Show] and the other with [Speaker Hide] to filter out individual speakers from the rest using the parameter [Display]. The bar chart with all the other speakers is ranked ascending.


      The issue I have is that when the Display parameter control is changed the ranking does not stay in order. It puts the row that was filtered out by the parameter at the end of the chart, rather than in the ranked order. It only does this the first time the parameter is used. The next time the parameter is used it reveals the hidden data again in the position it was ranked.


      I have attached a workbook showing my calculations and how I have created the dashboard. I have also attached the dummy data I have used if needed.


      Can anyone tell me why the ranking is not working when a parameter filters out some information, and also if there is a way to solve it?

       

      Thanks

       

      Emma

        • 1. Re: Parameter Control Affects Ranking Order
          Tracy Rodgers

          Hi Emma,

           

          Place Speaker Name on the columns shelf and sort it in the desired order before placing Speaker Hide anywhere on the view. Once the sort is in order, THEN place Speaker Hide to the left of Speaker Name, right click and hide the Hide column. Now, when you change the parameter, they should stay in order.

           

          Hope this helps!

           

          -Tracy