1 Reply Latest reply on Apr 27, 2012 6:54 AM by Robert Morton

    problems with Linked Queries

    Christian Hundemer

      Error:

      Microsoft SQL Server was unable to establish an impersonated database

      connection. Unable to connect to the server "xxxxx-xxxxxxxxx". Check that the

      server is running and that you have access privileges to the requested database

       

      Background:

      SQL 2008 (Datasource), Latest version of tableau. The impersoanted account is DBO (for now) for the datasources.

       

      Observations:

      We have a dashboard report that comes from a variety of sources. Data that is stored in the DB is being reported correctly, However, all data sources that are linked queries(to external sources) are giving me the error above.  Running tableau locally works great but when published to the server it breaks. I know I must be missing some sort of configuration...Dones not make sense but do I have to give permission to each external source (the link is already running under an account)?

       

      HELP....If I dont get this up running soon my boss is going to suggest i be a Walmart greeter

        • 1. Re: problems with Linked Queries
          Robert Morton

          Hi Christian,

           

          Using the Impersonation feature with SQL Server requires a bit of configuration on SQL Server to work properly. Furthermore, it is likely not possible to use SQL Server impersonation with linked views, since those views may point to other databases which cannot support the same security rules. I suggest that you turn off Impersonation for those data sources which are linked views when you publish from Desktop to Server.

           

          Also note that Tableau Desktop does not perform SQL Server impersonation, since you are connected directly and there is nobody to impersonate. Since Tableau Server does perform SQL Server impersonation, any errors you see will first appear in the Tableau Server environment.

           

          -Robert

          1 of 1 people found this helpful