2 Replies Latest reply on Apr 19, 2012 6:36 AM by Nick Conner

    Error publishing SharePoint odata To Tableau Server

    Nick Conner

      I just started playing around with connecting to data stored in our company's SharePoint implementation, and was able to make some proof of concept views by combining data and content stored in SharePoint lists. So far so good!

       

      Unfortunately, when I went to post to our Tableau Server dev project to share with the rest of my team I was stopped by an erroneous error:

      Unable to parse XML response from website. <!DOCTYPE *general doctype info*> <html><head>

       

      In desktop the connection and analysis works perfectly. It is only when either trying to post the data connection or workbook to Server that I get the error.

       

      I'm new to this, but it seems like maybe something in the odata feed from SharePoint may be malformed and cause the XML based structure of tableau files to fail parsing during the publishing process? Or something? Anyone?

       

      The error occurs after entering my Server credentials in desktop, but before the next publish dialog pops up. This has not been an issue with any of our normal workbooks/connections.

        • 1. Re: Error publishing SharePoint odata To Tableau Server
          James Baker

          This is happening in the login phase - I think this error indicates that you're not actually talking to Tableau Server.

           

          Check the Tableau Server server name and the port number in the Desktop login dialog again.  I dunno, make sure you didn't type the SharePoint server name by mistake or something?

           

          I might be wrong - it's weird that you'd have problems logging in only for this workbook/datasource.  But before the next publish dialog shows up, you haven't actually published the current document.  Try this experiment: Open the workbook, then select Server -> Login instead of Server -> Publish workbook.  Can you login successfully?  If so, then try to publish after logging in - do you get the same error?

          • 2. Re: Error publishing SharePoint odata To Tableau Server
            Nick Conner

            This was definitely in the ballpark of the issue...weird.

             

            I was using the correct login, and actually was able to publish another workbook using another SharePoint oData connection, immediately after building this first workbook, without any issue.

             

            When I sat down this morning, reconnected to VPN, and attempted to login again (was going to play around with your suggestions above), it magically worked. Not sure what got tangled up here, but it was definitely login related as you suggested. I'll keep that in mind if I ever hit the same issue again.

             

            Thanks!