1 Reply Latest reply on Feb 21, 2012 5:18 PM by Daniel Hom

    Tableau viz in my WordPress Blog does not show up

      Hi,

      I would like to post my Tableau viz in my WordPress Blog found at:

      http://thebitbox.wordpress.com

      Unfortunately, all I am getting is a blank space.

      Below is the embedded Tableau code:

      <script type="text/javascript" src="http://public.tableausoftware.com/javascripts/api/viz_v1.js"></script><div class="tableauPlaceholder" style="width:654px; height:2595px;"><noscript><a href="#"><img alt=" " src="http://public.tableausoftware.com/static/images/Ph/Phil_ImportExport_ASEANRev2/PhilippineImport-ExportDashboard/1_rss.png" style="border: none" /></a></noscript><object class="tableauViz" width="654" height="2595" style="display:none;"><param name="host_url" value="http%3A%2F%2Fpublic.tableausoftware.com%2F" /><param name="site_root" value="" /><param name="name" value="Phil_ImportExport_ASEANRev2/PhilippineImport-ExportDashboard" /><param name="tabs" value="yes" /><param name="toolbar" value="yes" /><param name="static_image" value="http://public.tableausoftware.com/static/images/Ph/Phil_ImportExport_ASEANRev2/PhilippineImport-ExportDashboard/1.png" /><param name="animate_transition" value="yes" /><param name="display_static_image" value="yes" /><param name="display_spinner" value="yes" /><param name="display_overlay" value="yes" /><param name="display_count" value="yes" /></object></div><div style="width:654px;height:22px;padding:0px 10px 0px 0px;color:black;font:normal 8pt verdana,helvetica,arial,sans-serif;"><div style="float:right; padding-right:8px;"><a href="http://www.tableausoftware.com/public?ref=http://public.tableausoftware.com/views/Phil_ImportExport_ASEANRev2/PhilippineImport-ExportDashboard" target="_blank">Powered by Tableau</a></div></div>

      Hope you can help me very, very soon.

      Thank you very much!
      John

        • 1. Re: Tableau viz in my WordPress Blog does not show up
          Daniel Hom

          Hi John,

           

          Wordpress is sometimes known to have some issues with Tableau embeds. Can you try refreshing your view? If it's still blank, you may need to use an iframe instead.

           

          Rather than use the standard embed code that you pasted, use this instead:

           

          <iframe src= "[here type in the URL link for the viz]" scrolling="no" width="[here type in the width]" height="[here type in the height]" frameborder="0"></iframe>

           

          This has worked for me in the past when trying to embed Tableau vizzes into Wordpress blogs, and I know it's worked for others as well. Let me know if that works for you.

           

          Cheers,

          Dan