7 Replies Latest reply on Feb 18, 2012 2:55 PM by Guy Shechter

    Edit Set error

    Matt Lee

      When using Tableau 7, I tried to edit a Set that I created, but I get a dialog box that says, "Schema::Get Index".

       

      It seems to happen when I try to add another item to an already existing Set.  I've attached a screenshot of the error that comes up.  I click "OK" to continue editing my set, but it still pops up again.  Seems it could be bug?

        • 1. Re: Edit Set error
          Ujval Gandhi

          Hi Matt

           

          Sorry for being dense - but how were you able to add another item to an already existing set - I cannot figure out how to do that; Can you please explain ?

           

          Regards

          • 2. Re: Edit Set error
            Francois Ajenstat

            Matt - Which Beta version are you using? Also, can you send a copy of your packaged workbook and desktop logs to beta@tableausoftware.com so we can investigate the issue.

            • 3. Re: Edit Set error
              Matt Lee

              Hi Francois. I'm using the latest Beta - version 8. How do I send the desktop logs? I will send the packaged workbook over to you guys to see the issue. I still get the error when I try to edit my set.

              • 4. Re: Edit Set error
                Matt Lee

                Hi Ujval - To edit a set, you just click on the Set you created, right-click and select "Edit".  Hope that helps!

                • 5. Re: Edit Set error
                  Francois Ajenstat

                  Hi Matt - create a zip file of the files under your 'My Documents\My Tableau Repository (beta)'\logs'

                  Send me an email if you have any issues.

                   

                  Thanks in advance

                  • 6. Re: Edit Set error
                    Ujval Gandhi

                    Sorry Matt, I don't see that option. Screenshot is attached of what I see when I right click the Set

                    • 7. Re: Edit Set error
                      Guy Shechter

                      I just got the same error with the official release of 7.0.

                       

                      I set up a live connection to an Excel data sheet. (btw, I tried to extract the data from the Excel, and it made no difference).

                       

                      I created a worksheet with the following setup:

                      • Columns: One Dimension, plus "Measure names"
                      • Rows: "Measure Values"
                      • Measure Values consisted of 5 independent measures that were individually SUM()ed

                       

                      After I got all this plotted, I tried to drag one more Dimension into the Label and/or Color area. That is when the program threw a Schema::GetIndex error. When I removed the offending Dimension from the Label and Color area, then the error went away.

                       

                      What I then did was create a new worksheet, but started first by adding the offending Dimension into the Label and Color area, before composing the rest of the elements. And, surprise, it worked.

                       

                      Conclusion, it's not the data, rather, it is the order in which you add the elements to your worksheet graphic.