Skip navigation

Easy way to disable automatically aliasing columns

score 126
You have not voted. Active

For some reason Tableau renames columns when connecting to a data source.

 

For example, a column named "has_AIDS" is automatically renamed to "Has Aids".  Not the same.

 

Prior to Tableau 9, this annoying behavior could be switched off by adding a  -DADM=0 to the end of the Tableau shortcut.  Full instructions here: http://community.tableau.com/message/282042.

 

In Tableau 9, this workaround no longer works.  But there is a new, much more laborious workaround:

 

1. Connect to the data source, go to a worksheet and save the connection as a .tds file by right clicking on the data source and selecting 'Add to Saved Data Sources...'. Disconnect from the data source.

2. Open the saved data source with a text or xml editor.

3. Search for the xml tag '<aliases enabled='yes' />' and change 'yes' to 'no'.

4. Reconnect to the saved data source (.tde)

 

I would love to be able to check off a box that says "Don't rename the columns in the database". 

 

The DB architect went to a lot of trouble to name the columns.  It amazes me that the default behavior is to override it  AND provide no easy way of turning it off.

 

 

 

* title of idea modified for clarity/search

Comments

Vote history