2 Replies Latest reply on Mar 25, 2019 10:37 AM by Luke Bullard

    Install Server (Ubuntu 16.04) lsb-core Issue

    Luke Bullard

      I'm trying to install Tableau Server on a clean Ubuntu 16.04 installation. When I run the gdebi -n <installer.deb>, I get:

      This package is uninstallable
      Cannot install 'lsb-core'
      

       

      After reading up on this, lsb-core has been removed from Ubuntu's 16.04 repo's and it is only available on 14.04, which has it's EOL coming up next month.

       

      I tried adding the 14.04 repos to my sources.list, so then it picked up that the lsb-core package exists, but lsb-core wanted a bunch of 14.04 versioned dependencies that would conflict with the already installed 16.04 version of the same package.

      At this point, I decided this is super hacky and I don't want to go through a mess trying to update packages in the future across 14.04 and 16.04 repos/dealing with lsb-core maybe not getting updated after 14.04 EOL/etc.

       

      Has anyone dealt with this before or does anyone please have any ideas?

       

      Thanks in advance.