1 Reply Latest reply on Mar 4, 2019 2:44 PM by Vanya Tucherov

    Could not find suitable distribution for Requirement.parse('Tornado-JSON')

    Aftab Parvaiz

      I am getting the following error as I run the startup.cmd to start the service

       

       

      Installed c:\progra~1\tabpy\sandbox\lib\site-packages\tabpy_server-0+unknown-py3.7.egg
      Processing dependencies for tabpy-server==0+unknown
      Searching for Tornado-JSON
      Reading https://pypi.org/simple/Tornado-JSON/
      Download error on https://pypi.org/simple/Tornado-JSON/: [WinError 10061] No connection could be made because the target machine actively refused it -- Some packages may not be found!
      Couldn't find index page for 'Tornado-JSON' (maybe misspelled?)
      Scanning index of all packages (this may take a while)
      Reading https://pypi.org/simple/
      Download error on https://pypi.org/simple/: [WinError 10061] No connection could be made because the target machine actively refused it -- Some packages may not be found!
      No local packages or working download links found for Tornado-JSON
      error: Could not find suitable distribution for Requirement.parse('Tornado-JSON')
      

       

      When I try to install Tornado-JSON (I have a proxy) I get the message that Tornado-JSON is installed

       

      C:\Windows\system32>pip install --proxy="" --index-url=https://my-proxy.com/repository/pypi-proxy/simple Tornado-JSON==1.3.3 
           Looking in indexes: https://my-proxy.com/repository/pypi-proxy/simple Collecting Tornado-JSON==1.3.3 
           Using cached https://my-proxy.com/repository/pypi-proxy/packages/24/79/20ddcf876803af829999f9b4955fd92ae83914b0680304d9c687a039a9b7/Tornado-JSON- 1.3.3.tar.gz 
           Requirement already satisfied: tornado>=3.2.2 in c:\program files (x86)\python37-32\lib\site-packages (from Tornado-JSON==1.3.3) (5.1.1) 
           Requirement already satisfied: jsonschema>=2.3.0 in c:\program files (x86)\python37-32\lib\site-packages (from Tornado-JSON==1.3.3) (2.6.0) 
           Installing collected packages: Tornado-JSON Found existing installation: Tornado-JSON 1.3.2 Uninstalling Tornado-JSON-1.3.2: Successfully uninstalled Tornado-JSON-1.3.2 
           Running setup.py install for Tornado-JSON ... done Successfully installed Tornado-JSON-1.3.3`
      

       

      Im stuck now.

      Where do I go from here?