3 Replies Latest reply on May 20, 2019 4:05 AM by john howitt

    Tableau server application server status error

    Santhosh Sekar

      Hi,

       

      All of sudden my application services are not coming up after Tableau machine restart.

       

       

      Any troubleshooting steps? We are having Tableau server 2018.2.2. Any help much appreciated!

        • 1. Re: Tableau server application server status error
          Santhosh Sekar

          Hi,

          Can anyone have any insights here?

          Thank you

          • 2. Re: Tableau server application server status error
            Mark McGhee

            Hi Santhosh,

             

            So depending on what version of Tableau Server that you're running most of the "startup" type issues are captured in either TSM.log (for versions 2018.2.x and higher) or Tabadmin.log (for 2018.1.x and lower).   That would be the first log file I'd check to see if there's anything obvious like possibly a port got grabbed by another application or is now possibly blocked.

            • 3. Re: Tableau server application server status error
              john howitt

              I have just been working in this are and here re a couple of things i found. Initially Gateway 0 was not running when i started the serve. This was due to my system booting up Apache before Tableau got to it  To clear this i disable automatic Apache startup in systemctl. Application server 0 failing for me was due to a quirk i have not yet sorted but in  /var/opt/tableau/tableau_server/data/tabsvc/config/gateway_0.20191.19.0215.0259/security/ i have a file called privkey1.pem that is part of my SAML setup and when i run an apply pending changes this file is emptied to 0 bytes and Tableau just silently fails. As i say i am tracking this down but in the meantime what i do when saying yes to apply i monitor the files state with an ls -lart and when i see it flip to 0 bytes i just copy a new version in.