1 Reply Latest reply on Oct 30, 2018 8:51 AM by Ken Flerlage

    [Help] MongoDB Bi Connector | Error: conn4] handshake error: ERROR 1759 (HY000): ssl is required when using cleartext authentication

    Diego Araujo

      Hello All,

       

      I appreciate if you guys could help me. Its been more than 2 months I am trying to figure out how to connect on MongoDB with password and SSL certificate, with out success.

       

       

       

      I am trying to authenticate on MongoDB using Tableu Mongo BI Connector but I am getting this error:

       

      I am using the Mongo DB Connector for BI 2.5 with this connection string to bind the port 3307:

       

      mongosqld.exe /auth /u admin /p password --mongo-uri=mongodb://mongodb:27017 /mongo-ssl /mongo-sslPEMKeyFile:C:\temp\mongodb.pem

       

      I am using the same SSL PEM key that is configured on MongoDB server.

       

       

      I am getting the following error on mongosqld log file:

       

       

      2018-10-22T18:47:47.897+1100 I NETWORK    [initandlisten] waiting for connections at 127.0.0.1:3307

      2018-10-22T18:47:47.897+1100 I SAMPLER    [schemaDiscovery] initializing schema

      2018-10-22T18:47:47.935+1100 I SAMPLER    [schemaDiscovery] sampling MongoDB for schema...

      2018-10-22T18:47:47.936+1100 I SAMPLER    [schemaDiscovery] no namespaces were sampled

      2018-10-22T18:47:52.446+1100 I NETWORK    [conn1] connection accepted from 127.0.0.1:57132 #1 (1 connection now open)

      2018-10-22T18:47:52.446+1100 E NETWORK    [conn1] handshake error: ERROR 1759 (HY000): ssl is required when using cleartext authentication

      2018-10-22T18:47:52.447+1100 I NETWORK    [conn1] end connection 127.0.0.1:57132 (0 connections now open)

       

       

      That is the connection throw Tableu MongoDB BI Connector option, I using the same SSL certificate of MongoDB server " mongodb.pem "

      Screen Shot 2018-10-22 at 5.47.49 pm.png

       

      That is my  Mongodb environment:

       

      MongoDB server with authentication and SSL:

       

      I have configured the SSL on MongoDB server

      ----------------------------------------------------------------------------------------------------------------------------

      # network interfaces

      net:

        port: 27017

        bindIp: 0.0.0.0

       

        ssl:

          mode: requireSSL

          PEMKeyFile: /etc/mongodb/ssl/mongodb.pem

          allowConnectionsWithoutCertificates: true

          allowInvalidCertificates: true

       

      security:

         authorization: enabled

      #operationProfiling:

       

      ----------------------------------------------------------------------------------------------------------------------------

       

      Thank you in advance

       

      Diego Araujo