1 Reply Latest reply on Oct 15, 2018 3:58 PM by ShivaRam Chennapragada

    Filters messed up after URL link action

    Guillermo Perez

      I have a a table in a dashboard that when an element is clicked it links to another dashboard and sets certain dimensions to whatever the clicked element had.  Once I click and go to the second dashboard, everything is fine but then if I try to change the dimension filters (the same dimensions passed in the URL) all the sheets that are using another data source (not the filters native source but they are blended) go blank.

       

      In short

      Once I click and and go to the next dashboard, changing the filters to check another element  makes some charts go blank.

       

      If I am using the second dashboard by itself( i,e not getting to it by the url action)  everything is fine and can change the filter values

       

       

      Has anyone had any similar issues?

       

      Sorry this is a hard one to put an example.

        • 1. Re: Filters messed up after URL link action
          ShivaRam Chennapragada

          If I understand your question correctly you're trying to filter the content on Dashboard B using a URL action on Dashboard A and then applying dimension filters on already filtered Dashboard B correct? If your filters are set to 'All values in Hierarchy' or 'Context' or 'Relevant Values' and preceding filters doesn't have anything relevant the dashboard would turn blank. Consider this example, I have two countries Canada and USA. Using URL I passed Canada as my filter values to next dashboard, so in my dashboard B I see Canadian states but in dimensions filter I'm selecting Texas state then it would turn blank. Make sure you're showing all values when clearing filters, have filters applied to worksheets, etc.,

           

          Hope this helps. If not, please attach a packaged workbook so it's easy to troubleshoot.

           

          Best,

          Shiva.