3 Replies Latest reply on Oct 2, 2018 11:39 AM by stephen.pollak.0

    Added field in source file is missing from steps

    garth.conrad

      I have a working Tableau Prep flow. The source file is an excel workbook. The workbook was updated to include a new column of data and saved as new name. Within Prep under connections I edit the source to point to the new file.  The data imports, no issues.  The first step in the flow is the input step which lists all the fields.  The added column of data in the excel file shows up as a field, the "sample values" shows values and the box is checked for the data to import.

       

      Move to the second step in the flow, a cleanse step. The added field does not show up. Same on the remaining steps in the flow, the field is not present.

       

      I have tried refreshing the data, no help.

      I have tried reconnecting the source file, no help.

      I have tried changing the sampling method, no help.

      I have tried adding a new step between the input block and the first cleanse step, no help.

       

      Without rebuilding the flow from scratch (colossal waste of time), I am not sure how to resolve this.  Any ideas?

       

      G

        • 1. Re: Added field in source file is missing from steps
          Scott Anderson

          Hmm. During your cleanse step, did you take any "keep only" actions?

          • 2. Re: Added field in source file is missing from steps
            garth.conrad

            The cleanse step added a filter (exclude values) on a different field. I did try removing the cleanse step altogether thinking that may had been the source of the issue, no help.  The new field is still not showing up in subsequent steps.

             

            I ran a test building two simple excel files. One contained 3 columns and one 4 columns. I built a Prep flow based on the 3 column file, saved and closed.  Then I reopened and switched the source to the 4 column file. Everything updated correctly.  All 4 columns show up in every step.

             

            The original excel file has approx 100k rows by 60 columns (...then 61 columns). Not sure why source switching works with small files versus  large files but for now I am done using Prep for this particular application.

             

            Tableau please fix this software!

             

            G

            • 3. Re: Added field in source file is missing from steps
              stephen.pollak.0

              Hi.

               

              I have a similar problem perhaps.

               

              A field fails to appear in Steps but is in the Source view. 

               

              This field was added, with others, after the Tableau Prep workflow was first set up.

               

              The other fields, added after the initial setup, appear, except for this one.

               

              Rebuilding the workflow from scratch is not, as one might surmise, an appealing option.