1 Reply Latest reply on Oct 11, 2018 4:00 PM by Patrick A Van Der Hyde

    Changing layout and content in publishing from Tableau Desktop to Tableau Server

    Sara Vezzalini

      Hi everybody,

       

      I have a problem when publishing a dashboard on Tableau Server. I am working for a client so I have a Tableau Creator account and a Tableau Explorer account; I use the latter to check the publishing.

       

      This is what I see in Tableau Desktop (correct functioning)

      Step 1: A predictive cone graph and a histogram

       

      1.png

       

      Step 2: I select a point on the graph and then all the other analysis appear by actions

      2.png

       

       

       

      This is what I see in Tableau Server

      Step 1: A predictive cone graph and NOT the histogram

      3.png

       

      Step 2: If I select a point on the graph, nothing happens

       

      4.png

       

       

       

       

      Moreover:

      • Option A: the dashboard works correctly using Tableau Desktop but it doesn’t if using Tableau Server (Tableau Creator account).
      • Option B: the dashboard works correctly using Tableau Desktop and Tableau Creator account but it doesn’t if using Tableau Explorer account.
      • Option C: If I use my laptop, the dashboard works correctly both in Tableau Creator account and Tableau Explorer account. But if I change laptop – using the same browser or not - it could work properly or not. It seems it’s related to the laptop and/or the browser I’m using.
      • I noticed that if the dates in the cone graph are in English, then the actions work, whereas if the dates are in Italian, they don’t work and the histogram is disappeared. I don't know why it changes language.

       

      What I’ve done so far:

      • I published the dashboard on the server after deselecting any points on the graph
      • The date field in my data source is a string: “1” for March 2018, “6” for September 2018 and “12” for March 2019. So I needed to transform it into a date field.

      At the beginning, the dates were in this format: DATE(“MM/DD/YYYY”). While passing from Tableau Desktop to Tableau Server, dates were misread and as a result different dates coincided to the same one. The resulting graph was like a cross. I tried to change the format in DATE(“DD/MM/YYYY”) – as the correct Italian date format is DD/MM/YYYY. I used also the function DATEADD(). The solution was “forcing” the dates in this format: #YYYY-MM-DD# and the cross disappeared.

      • I set the same language (Italian) on the browser, on Tableau Desktop, on Tableau Server and on the laptop.
      • I set the Workbook locale to Italian (from File > Workbook Locale); at first it was set to Automatic.
      • I set the Server locale to Italian (from File > Workbook Locale); at first it was set to Automatic.

       

       

      I think it could be a problem about dates and some settings related.

      What do you think? Do you have an idea how to solve this problem?

      Thank you very much!

       

       

      Sara