4 Replies Latest reply on Jul 30, 2018 9:39 AM by Michael Kaminski

    E-mail Subscriptions work - sometimes, sometimes not

    Michael Kaminski

      I am currently publishing workbooks (Tableau 2018.1.3) to our Tableau server (Server 2018.1.1).  I update these workbooks manually, once a week, or once a month, because the source of the workbook's data extract, and our Tableau server, are on separate clouds.  (We are currently moving our databases to the same cloud, which will then allow the Tableau server to talk to our databases and update these workbooks automatically.) However, after I perform my manual updating, I publish the workbook, and run the E-mail subscription that I have previously set-up.  Sometimes this works just fine. Sometimes it doesn't!  I can't figure out why.  I've gone through the settings of each subscription, to each workbook.  I can't see any conflicts there.  All I can think of is that publishing a new workbook is overwriting the old workbook and this also deletes the subscription.  So....When I overwrite a the old workbook (currently on the server) with a new workbook, I am sometimes deleting it's subscription?  But this doesn't happen to every workbook that I update. Every new workbook that is published, I check to confirm that all of the correct people are still on the subscription list - which they are.  I'll then go to the schedule page, and manually run the subscription.  On some workbooks the subscription runs, some it doesn't! Any help as to why this is happening only 50% of the time and with no subscriptions being deleted, that I can tell?

       

      Thanks, Mike.

        • 1. Re: E-mail Subscriptions work - sometimes, sometimes not
          Don Wise

          Hi Michael,

          Not sure if this troubleshooting help guide will work for you?  Troubleshoot Subscriptions  Thx, Don

           

          P.S. If under admin - > Maintenance -> Background Tasks shows successful, then perhaps the issue lies with the mail server, or the white list needs to be updated to allow for the subscription email to pass through?

          • 2. Re: E-mail Subscriptions work - sometimes, sometimes not
            Andrew Bickert

            Hi Michael,

            You could also check through the backgrounder logs to see if there are any issues in there, do a search on a username of a person whom should be receiving the email subscription. We had an issue with subscriptions that wouldn't send because the "Don't send if view is empty" was selected (even though the view was never empty) and was able to troubleshoot that through the logs.

             

            Andrew

            • 3. Re: E-mail Subscriptions work - sometimes, sometimes not
              Michael Kaminski

              Thanks Andrew, I will check the logs. BUT, the thing is, the E-mail subscription will either go out to everyone (all user names) on the list, including myself, or no one at all. I'll still check it out.  Something to include, after I made my original post, I opened one of the workbooks that wouldn't send and deleted to subscriptions that were shown.  I then subscribed the same people again. Again, I ran the subscription and it went through. That makes me think I deleted the original subscription when overwriting with the new workbook? But all the original subscriptions still showed up after the publishing of the new workbook.

              • 4. Re: E-mail Subscriptions work - sometimes, sometimes not
                Michael Kaminski

                Thanks Don, it could be a white list issue.  I will check with our IT person who handles that stuff.  As stated to Andrew (above) after I made my original post, I opened one of the workbooks that wouldn't send and deleted the subscriptions that were shown.  I then subscribed the same people again. Again, I ran the subscription and it went through. That makes me think I deleted the original subscription when overwriting with the new workbook? But all the original subscriptions still showed up after the publishing of the new workbook.