1 Reply Latest reply on Aug 9, 2018 3:48 PM by Patrick A Van Der Hyde

    Creating extract fails after interactive step of WDC

    Alex Marcotte

      Hello,

       

      I created a WDC that fetches data being streamed from a REST endpoint. The interactive step asks a few questions to the user then sends a POST to an endpoint followed by a GET to another endpoint, the latter returning the results as a stream.

       

      For smaller result sets, this works without any issues. The extract is created fairly quickly too. I'm now testing with larger data sets and getting the following error:

       

      Tableau failed to create an extract. This data source requires an extract before you can start your analysis.

       

      Click Edit Data Source, and then click the sheet tab to create the required extract.

      Click Continue to proceed without creating the required extract.

      An error occurred while communicating with data source 'My WDC Connection'.

       

      The connection to the data source might have been lost.

      ReadBytes: Communication with the Tableau Protocol Server process was lost.

       

      Unable to create extract

      No details available.

       

      For reference, if I bypass the WDC and manually go fetch the result set, the file contains ~14 million rows with 11 columns. The columns consist mostly of small integer values (two of the columns are between 0 and 10 in 80% of the cases), one is a date in YYYY-MM-DD format and the rest are short strings. Beside the error above (which I get in Tableau as a popup after about 20-25 minutes) the logs don't display any error. The tabprotosrv.txt file has millions of lines like this:

       

      {"ts":"2018-07-24T15:28:51.242","pid":65167,"tid":"a8748","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"web-data-connector","v":"Looking for table id 'my_wdc_table'. Number of tables is 1","ctx":{"client-type":"desktop","procid":"65040","tid":"688821","version":"20181.18.0706.1237"}}

      {"ts":"2018-07-24T15:28:51.242","pid":65167,"tid":"a8748","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"web-data-connector","v":"Next id is 'my_wdc_table'","ctx":{"client-type":"desktop","procid":"65040","tid":"688821","version":"20181.18.0706.1237"}}

      {"ts":"2018-07-24T15:28:51.242","pid":65167,"tid":"a8748","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"web-data-connector","v":"ReadRows: numrows='1'","ctx":{"client-type":"desktop","procid":"65040","tid":"688821","version":"20181.18.0706.1237"}}

      {"ts":"2018-07-24T15:28:51.242","pid":65167,"tid":"a8748","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"web-data-connector","v":"Done reading rows. Valid Data = 1","ctx":{"client-type":"desktop","procid":"65040","tid":"688821","version":"20181.18.0706.1237"}}

       

      Is there any way I can troubleshoot this any further? I should mention this is entire on Tableau Desktop. The WDC is also running as a Javascript application locally but I ran into the same problem deploying it on AWS.

       

      Build Number: 2018.1.3 (20181.18.0706.1237) 64-bit

      OS: macOS High Sierra (10.13.5)

      Specs: 2.2 GHz Intel Core i7, 16 gigs of memory, more than enough disk space

       

      Thanks