4 Replies Latest reply on Aug 13, 2018 9:36 AM by Andrew Blake

    Data source is "out of date" and won't refresh in Tableau Server

    Andrew Blake

      I have a project that connects to multiple different PostGres databases via extracts. Uploading the projects to our company Tableau server is no problem, but the scheduled refreshes almost always fail, even though I have embedded all of the passwords when publishing the project. One single time it worked, but I don't know why. I have tried letting them refresh when I'm logged into my company's VPN as well as having the databases connected and open in PostGres; also, I've tried letting them refresh when away from my computer. Either way, it's the same sad story. Can anybody explain what is going on?

      Here is an example of the error I get on the Tableau server page:

       

      Screen Shot 2018-07-24 at 1.30.00 PM.png

      From here, I click "Connection Details" to edit the connections in the Data Sources page of the project, and I see this:

       

      Screen Shot 2018-07-24 at 1.40.39 PM.png

      (The server port in this example is "-------" because this particular source connects two different PG databases in a join, but I have some other sources with just one connection, and the port # is shown.) Everything looks fine to me, so I don't know what to do.

       

      Thank you!!!

       

      P.s. I can't post any packaged workbooks because the data contains sensitive company information.