12 Replies Latest reply on May 29, 2018 9:28 AM by Toby Erkson

    Manual update is needed for worker

    Tobias Ruby

      Hi guys,

      hope one of you can help me!

       

      I have a Tableau Server of v10.4.6 (10400.18.0404.0923) running as a primary.

      When adding a worker, I receive this warning/error: "One or more workers could not be upgraded automatically. for this upgrade, the worker installer version and server installer version must match. Please manually upgrade the workers or remove the workers' configuration.".

      However, both machines are running on v10.4.6 (10400.18.0404.0923).

       

      The following are log entries of tabadmin on the primary:

      2018-05-10 21:36:06.966 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ Local admin version = 10400.18.0404.0923

      2018-05-10 21:36:06.982 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ Running version on worker1: 10.0.0.218:3730

      2018-05-10 21:36:06.997 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ For worker 1, remote version = 10400.18.0404.0923. Does not need updating.

      2018-05-10 21:36:07.280 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ Sending C:/Program Files/Tableau/Tableau Server/10.4/primary_installed_features.txt to worker 1

      2018-05-10 21:36:28.750 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ 0 bytes written before failure

      2018-05-10 21:36:28.750 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ Manual update is needed for worker 1

      2018-05-10 21:36:28.920 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ Local software version = 10400.18.0404.0923

      2018-05-10 21:36:28.920 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ Running version on worker1: 10.0.0.218:3730

      2018-05-10 21:36:28.106 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ For worker 1, remote version = 0. Does need updating.

      2018-05-10 21:36:28.122 +1000_ERROR_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ Workers out-of-date: #1

      2018-05-10 21:36:28.122 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ prep_worker Handling MultiCommand::ReportableError Workers out-of-date: #1

      2018-05-10 21:36:28.122 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ Received ExitWithStatus, code 206

      2018-05-10 21:36:28.122 +1000_DEBUG_10.0.0.17:WIN-56K4ESU2CT4_:_pid=9508_0x2264ea32__user=__request=__ file:/C:/Program Files/Tableau/Tableau Server/10.4/bin/tabadmin.jar!/lib/commands/prep_workers.rb:58:in `run'

      file:/C:/Program Files/Tableau/Tableau Server/10.4/bin/tabadmin.jar!/lib/multicommand.rb:255:in `dispatch'

      file:/C:/Program Files/Tableau/Tableau Server/10.4/bin/tabadmin.jar!/bin/tabadmin.rb:35:in `(root)'

      org/jruby/RubyKernel.java:1058:in `load'

      file:/C:/Program Files/Tableau/Tableau Server/10.4/bin/tabadmin.jar!/bin/tabadmin.rb:1:in `(root)'

      org/jruby/RubyKernel.java:1033:in `require'

      file:/C:/Program Files/Tableau/Tableau Server/10.4/bin/tabadmin.jar!/META-INF/main.rb:36:in `require'

      <script>:3:in `(root)'

       

      What am I doing wrong? The log states first both versions are matching, still failing 20 seconds later with the message there is a version difference.

      If I can help with any further logs, just let me know.

       

      Best regards

      Toby