2 Replies Latest reply on May 10, 2018 8:46 AM by Nilim Borua

    Error when Publishing Data Source with connection to Salesforce.com

    Nilim Borua

      We are thaving trouble publishing Data Source extracts to Tableau Server that has a Salesforce.com connection.

       

      We are on Tableau server 10.4.3 and the server is behind a Proxy. So we have a Forward proxy in order to connect to Salesforce.com.

       

      We are able to connect to Salesforce.com through Tableau connector and create Data Source. We also see the data retrieved from the salesforce.com connection. However, when we try to publish the Data Source (which is an Extract by default), it fails and throws just a simple error message as below. We have tried lot of different things (including contacting Tableau Support too!) but nothing has seemed to help till now.

       

      We have another server which is NOT behind a proxy and open to the Internet. We are able to connect to Salesforce.com through Tableau and publish without issue. So looks like we are missing something when connecting through a Forward proxy server.

       

      Any help /suggestions regarding this would be of immense help. There is no way that we can have our Prod server open to the internet and hence it HAS to be behind he Firewall, so only option we have is to connect through Forward Proxy.

       

      Thanks in advance for your comments

        • 1. Re: Error when Publishing Data Source with connection to Salesforce.com
          Patrick A Van Der Hyde

          Hello Nilim,

           

          Please open a ticket with Tableau Support.  This issue sounds like a network related error that our Tableau Server team may be able to assist you in debugging.

           

          Good luck,

           

          Patrick

          • 2. Re: Error when Publishing Data Source with connection to Salesforce.com
            Nilim Borua

            Hi Patrick, I have raised a Support ticket long back and unfortunately Support has not been able to find out the issue and hence thought of trying out the Community in case someone has faced similar issue earlier.

             

            After trying a few things, we now see an error as soon as we try to connect to Salesforce.com : "The issuer certificate of a locally looked up certificate could not be found"

             

            The company Network guy says that it does not look likea proxy issue and server isnt trusting the cert its pulling from the external site.

            Is it required that the Tableau Server be too setup with SSL in order to connect to Salesforce.com on port 443? Our Tableau Server is NOT setup on SSL currently. The network logs show a lot of traffic to tableau.com, licensing.tableau.com, downloads.tableau.com when trying to connect to Salesforce.com.

            We recently setup Forward proxy just for connecting to Salesforce.com.

             

            Any idea regarding the same will be of lots of help. Thanks