5 Replies Latest reply on Oct 26, 2017 5:54 PM by Ghouse Shaik

    server alerts not working

    omer.kolodny

      Hi,

       

      I have set a new alert within the my dashboard and it has reached its threshold but the alert was not sent to me.

      The alert trigger worked properly and i have a few other alerts (when extracts fail) and they have stopped working as well.

      my email is defined correctly, anybody have any ideas?

      here is the screen shot of the trigger being turned on -

      Thanks!

        • 1. Re: server alerts not working
          Ghouse Shaik

          Hi Omer,

           

          Check at Tableau Server Background Tasks for Non-Extract Workbook. To Navigate to Background Task for Non-Extract Workbook shown in below screenshot.

           

          Steps To Navigate Background Tasks for Non Extracts.PNG

           

          In Background Task for Non Extract Workbook, Check that Alert is sent or not.

           

          Thanks & Regards,

          Ghouse.

          • 2. Re: server alerts not working
            omer.kolodny

            Hi,

             

            on what do i need to look at?

             

            here is a screen shot:

             

            no fail that i can see

            • 3. Re: server alerts not working
              Ghouse Shaik

              Hi Omer,

               

              Which option is Selected When you are Creating a Data Alert, When the Condition is true, Send Email.

              Create_Alert.PNG

              Go through the below image to check your Alert Option.

              Check Alert Option.PNG

               

               

              Which Option you are using in your Data Driven Alerts.

              • 4. Re: server alerts not working
                omer.kolodny

                Hi,

                 

                Yes i did choose the send email option and i even tried changing it to "as frequently as possible" . but still it doesn't seem to send the email. also i think it doesn't mail me when the extracts fail (although i check the option in the settings).

                 

                here is the screen shot:

                 

                • 5. Re: server alerts not working
                  Ghouse Shaik

                  Hi Omer,

                   

                  Thanks for providing the screenshot, As shown in the Screenshot, the first alert was checked at Oct 26, 2017, 12:19 PM and the Second alert was checked at Oct 26, 2017, 11:15 AM. At that it will increase the threshold value or not. If it is increased then it will triggers an Email alert otherwise not.

                  An example of drift on a server configured to check Daily:

                  * at 2PM on Daily the alert condition is checked and found to be true

                  * emails are queued as tasks, then sent out of the task queue when a background task channel picks them up (there might be other things in the queue ahead of them, e.g. a long running extract refresh that was queued at 1:50 pm)

                  * alert time is time are logged as when the email goes out, e.g. 2:10

                  * the following Daily at 2PM the server will look at this alert, and since a Daily hasn't yet transpired (it will at 2:10), it won't check that condition.

                   

                  Thanks & Regards,

                  Ghouse.