10 Replies Latest reply on Oct 5, 2017 2:02 PM by Toby Erkson

    HTTP 404 error

    John Kuo

      Hi All,

       

      I'm getting random 404 error on a two node cluster. Let's say it's Tabserve1 and Tabserve2. The error message is:

       

      HTTP 404 ERROR:
      UNABLE TO CONNECT TO THE SERVER "TABSERVE1".
      CHECK THAT THE SERVER IS RUNNING AND THAT YOU HAVE ACCESS PRIVILEGES TO THE
      REQUESTED DATABASE.

       

      I asked my network guy and this is his response:

       

      tabserve1.company.com is
      valid  tabserve1 is not valid.

       

      Most likely what is going on is
      you have some links pointed at the short name, which does often result in DNS
      errors.

       

      Usage of the short name would be
      an application level issue.

       

       

      So looks like the server is not using FQDN tabserve1.company.com. Where in the tableau server app can I correct this? Let me know what you think.

       

      Thanks!!!

       

      John

        • 1. Re: HTTP 404 error
          Jeff Strauss

          Hey John.  The most supported way to correct this is to go into the Tableau Server dialog, remove the worker, and then re-add the worker with the FQDN.  But it may also be feasible to fix this in both workgroup.yml and tabsvc.yml (on both nodes) while the server is stopped and see if this takes care of it.  But I wouldn't do this on prod...

           

          It's odd though that the short name is not working.  It could be a network policy at your shop, because at my shop, the servers are always connected via the short name and we have no issues.  When you are remoted into your primary, are you able to ping the worker shortname via a cmd window?  And vice versa?

           

           

          TC17?

          • 2. Re: HTTP 404 error
            John Kuo

            Yes, I'm hoping someone knows the command to fix this in the yml files.

             

            I'm going to TC17, can't wait! But I gotta figure out this issue first argh...

            • 3. Re: HTTP 404 error
              Jeff Strauss

              You can try going into your tabsvc.yml on your primary and find all references to your worker.

               

               

              And then issue a command such as the following for all references, and see if this works.

               

              tabadmin set worker.hosts worker1-fqdn, worker2-fqdn...

              tabadmin config

              tabadmin restart

              • 4. Re: HTTP 404 error
                Toby Erkson

                Jeff Strauss wrote:

                 

                ...

                 

                It's odd though that the short name is not working. It could be a network policy at your shop, because at my shop, the servers are always connected via the short name and we have no issues...

                Agreed.  I have users that use short names (even though they've been told not to do this) and they work.

                • 5. Re: HTTP 404 error
                  John Kuo

                  So it turns out I needed to log on as the run as user to modify my proxy settings to resolve the issues - i thought logging on as myself a member of Windows local admin group was enough but you must log on as the run as users (Configuring Proxies for Tableau Server ).

                   

                  By the way, don't use "tabadmin set worker.hosts" as it will mess up the configuration; I had to reinstall to fix it LOL.

                  2 of 2 people found this helpful
                  • 6. Re: HTTP 404 error
                    Toby Erkson

                    John,

                    Can you explain/show your proxy config changes?  I'm having an issue with getting to the Tableau mapping service on my 2-node test environment so I just want to make sure I've got mine set up correctly.  I've changed the settings using the Run As account (on both nodes) and it's good that you verified that it makes a difference.

                    • 7. Re: HTTP 404 error
                      John Kuo

                      Yep, here's what I did.

                       

                      Log on to servers using run as account (make sure it has admin rights on the boxes too) > IE > Internet Options > Connections > LAN Settings > Enter your proxy server URL and port (uncheck "automatic configuration" boxes and check both at the bottom) > Advanced > enter exceptions for internal traffic, e.g. for me I did *.wellsfargo.com, localhost, and names of the nodes.

                       

                      Just for good measures, let's make sure the proxy settings are pushed out to everyone on the nodes: Open a command prompt as administrator > enter this command netsh winhttp>import proxy source=ie  > close the window and you're done.

                       

                      Reboot the nodes and that should do the trick.

                       

                      2017-10-05_11-20-50.jpg

                      2017-10-05_11-22-10.jpg

                       

                      Cheers,

                       

                      John

                      • 8. Re: HTTP 404 error
                        Toby Erkson

                        Thanks John.  The only change I needed was to uncheck the "Use automatic configuration script" box, however, that didn't fix my particular situation.  Worth a try.

                        See ya at TC17

                        • 10. Re: HTTP 404 error
                          Toby Erkson

                          It does work if we use the regular server URL, however it does not work with our VIP (virtual IP) we are using.  I have a case with Tableau Support already and we're working on it.