6 Replies Latest reply on Sep 13, 2017 11:45 AM by Dipesh Surana

    Tabcmd - Cannot sign in because of missing arguments: --server

    Adam Olson

      I am trying to do a simple login and export of a workbook through Tabcmd. This was working until we had to upgrade to Tabcmd 10.3.1 after the upgrade to latest Tableau Server version. Below is my code which is as basic as possible.

       

                tabcmd login -s https://serverURL -u username -p password

       

                tabcmd export "workbook/view" --fullpdf --pagelayout landscape -f "C:\exportsavelocation\filename.pdf"

       

      Every time I run this code here is what is printed out.

              

                Creating new session

                Server: server URL

                Username: username

                Logging in as user 'username' since no --username flag was given

                     *** Cannot sign in because of missing arguments: --server

       

      It is almost like the Tabcmd is trying to log in a second time to execute the second line. When I add in the -s -u -p credentials at the end of the export line Tabcmd logs in again without completing the export. Or when I get rid of the export line all together there are no issues with Tabcmd logging in.

       

      What I have tried...

      1. --no-certcheck
      2. --cookie
      3. uninstalling Tabcmd and reinstalling after a fresh download
      4. Trying other commands instead of 'export' such as 'listdomains' and 'listsites'

       

      I also have full admin permissions. Thank you in advance for your help!

       

      ***Update

       

      Tableau recommends you to install Tabcmd at C:\tabcmd\ which I did. There seems to be another install of Tabcmd at C:\Program Files\Tableau\Tableau Server\10.3\bin. When using this location for the batch file everything works fine. I would prefer to keep everything in the C:\tabcmd\ folder because this folder is A LOT cleaner where things are less likely to get lost. Any thoughts as to what would be cause this confusing within the application?