12 Replies Latest reply on Jul 5, 2017 1:58 AM by Sivasankar Muthusamy

    TableauException error in publishing workbook through tabcmd

    Sivasankar Muthusamy

      I am recently started experiencing error in publishing the workbook through tabcmd.  While trying to publish the workbook using tab command,  I gets the below error.

       

      Error message-

       

       

      Extract of the tabcmd log file.

       

      [12184] DEBUG 2017-05-02 11:20:59,187: =====================================================================

      [12184] DEBUG 2017-05-02 11:20:59,192: ====>> Starting Tabcmd 10.1 at Tue May 02 11:20:59 UTC 2017 <<====

      [12184] DEBUG 2017-05-02 11:20:59,192: Build 10100.16.1103.2343

      [12184] DEBUG 2017-05-02 11:20:59,192: System.out encoding: Cp1252

      [12184] DEBUG 2017-05-02 11:20:59,192: Console codepage: 437   (OEM - United States)

      [12184] DEBUG 2017-05-02 11:20:59,192: Codepage identifier code: 437

      [12184] DEBUG 2017-05-02 11:20:59,192: Default locale: en_US

      [12184] DEBUG 2017-05-02 11:20:59,195: Display language: English

      [12184] DEBUG 2017-05-02 11:20:59,234: run as: tabcmd publish C:\Users\Desktop\Dashboard.twb -n PoC --db-username XXXX --db-password ********

      [12184] INFO  2017-05-02 11:20:59,329: Continuing previous session

      [12184] INFO  2017-05-02 11:20:59,329:     Server:   http://mytableauserver.com

      [12184] INFO  2017-05-02 11:20:59,329:     Username: XXXXAA

      [12184] DEBUG 2017-05-02 11:20:59,342: Connecting to url (GET): http://mytableauserver.com/vizportal/api/clientxml/auth/pubkey

      [12184] DEBUG 2017-05-02 11:20:59,770: Connecting to url (GET): http://mytableauserver.com/vizportal/api/clientxml/file_uploads/1586:F4898CA59AA64EE6BE1469AB8A10F47C-0:0/status

      [12184] DEBUG 2017-05-02 11:20:59,783: Resuming upload 1586:F4898CA59AA64EE6BE1469AB8A10F47C-0:0 from offset 412099

      [12184] INFO  2017-05-02 11:20:59,783: Publishing 'C:\Users\Desktop\Dashboard.twb' to the server. This could take several minutes...

      [12184] DEBUG 2017-05-02 11:20:59,785: Connecting to url (POST): http://mytableauserver.com/vizportal/api/clientxml/create/workbooks

      [12184] ERROR 2017-05-02 11:20:59,897: Internal server error

      TableauException

      [12184] DEBUG 2017-05-02 11:20:59,897: Finished at Tue May 02 11:20:59 UTC 2017

       

      Does anyone have experienced the above error and what will be the workaround to this ?