1 Reply Latest reply on Apr 26, 2017 2:10 PM by Patrick Van Der Hyde

    Seeing duplicated parameters when switching between published connection to local connection. Why?

    Mark Bradbourne

      We have a set of published connections, and for development purposes we will switch the connection to a local connection so we can execute Initial SQL to impersonate a user. When we do this we are seeing parameters get duplicated with a "1" at the end of the original name. Any idea what is causing this and how we can avoid it?

        • 1. Re: Seeing duplicated parameters when switching between published connection to local connection. Why?
          Patrick Van Der Hyde

          Hello Mark,

           

          Check out the FAQ:  Replace Data Source as a good starting place for these sorts of questions.   

           

          I'm not 100% sure but I think the issue encountered may be that there are many published data sources and the modifications for local testing are being done on just one of the data sources.  With my own visualizations, I make local copies of every data source in the workbook and then I go through and do the replace process to replace each server side data source with a local one.  Finally, i delete the server ones from the view so I am left with a local working copy.  This method doesn't produce duplicate fields, paramaters or cause problems for me.  I hope that works for you too. 

           

          I hope this helps,

           

          Patrick

          If this posts assists in resolving the question, please mark it helpful or as the 'correct answer' if it resolves the question. This will help other users find the same answer/resolution.  Thank you.