3 Replies Latest reply on Feb 14, 2017 7:20 AM by Nathan Panuco

    Map background not loading

    Tom Geyzen

      Hello,

       

      I am having some difficulties with a worksheet that plots custom polygons on a map.

       

      Tableau desktop and Tableau server are both running on the same PC. I have built a worksheet that plots custom regions on a map, and everything goes fine inside Tableau desktop (v 9.3.7). It both works with Tableau's built-in map as with MapBox maps.

       

      In the published version however, the background map doesn't show. Is doesn't show in the preview window (after publishing), it doesn't show in a webbrowser on the server, and it doesn't show in a webbrowser on a client PC. The URL to the Tableau or MapBox map is accessible from the server and client. Surprisingly, a very simple map with very little custom polygons works fine.

       

      I have cleaned the internet cache on both server and client and rebooted the server, but still no luck.

       

      Any ideas ?

       

      Cheers,

       

      Tom

        • 1. Re: Map background not loading
          Nathan Panuco

          Hi Tom!

           

          If the maps do not load at all, it sounds like the Tableau Server may not have access to download the maps or could be blocked because of Run As User permissions. What does F12 network console tab show in a web browser? Are there any 401s to your map server? You could also try experimenting with client/server side rendering.

           

          Testing with the URL Parameter

          To test server-side rendering on a session basis, type ?:render=false at the end of the view's URL. For example:

          http://localhost/views/Supplies/MyView?:render=false

          If client-side rendering is disabled on Tableau Server, enter ?:render=true to enable it for the session:

          http://localhost/views/Supplies/MyView?:render=true

          Hope this helps!

          • 2. Re: Map background not loading
            Tom Geyzen

            Hi Nathan,

             

            Thanks for your reply. I already tried your suggestions, but to no avail. As I mentioned in my post, a very simple map with very little data behind it renders fine. Moreover, the URL to the maps, be it Tableau or MapBox, are accessible from both the Tableau server and the client PCs. Tableau desktop and server run on the same machine, maps render ok in the desktop but even in a web browser on the server they don't show...

             

            Tom

            • 3. Re: Map background not loading
              Nathan Panuco

              What does it show in the F12 Network tab when you try and load it in Tableau Server? I've pasted below a screenshot of a successful map load showing the assets being downloaded (HTTP 200 codes)