4 Replies Latest reply on Feb 1, 2017 5:22 AM by Faris Ahamad M

    Calculated field boolean NULL

    Philipp Lidauer

      Hi girls and guys,

       

      in our data we got two integers. When they're equal something is 'true', so I created the following calculated field:

      By using ZN I avoid this returning NULL values, and that seems to work. But in the filter settings, NULL is shown nevertheless:

      German: falsch=false, wahr=true. How can I avoid NULL being shown here? I don't want to create more calculated fields than necessary, our users get distracted quite easily.

       

      (of course I searched quite a bit before asking here, didn't find anything)

       

      Many thanks!

      - P

        • 1. Re: Calculated field boolean NULL
          Mahfooj Khan

          Hi Philipp,

           

          Without seeing your underlying data it will be very difficult for us to give you any solution. Kindly provide some mock up data.

          Meanwhile you can try something like this. Don't know how much this help.

           

          IFNULL([Max Points],0)=IFNULL([Focus Points],0)

           

          Let us know If this help.

           

          Mahfooj

          • 2. Re: Calculated field boolean NULL
            Tharashasank Davuluru

            Hi Philipp,

             

            Di you try  not isnull()  function instead of ZN function. please try with this and let us know.

            1 of 1 people found this helpful
            • 3. Re: Calculated field boolean NULL
              Philipp Lidauer

              Thank you for your input! Unfortunately the outcome is the same.

               

              It seems that it's not an issue with the calculation but rather with the presentation, as with the following formula even without ZN or IFNULL there are no null values (again, Wahr = true):

               

              So I looked around some more and found the following:

              Somehow, when you select Only Relevant Values in the filter card, the NULL option disappeares. This is what I wanted The matter is strange nevertheless because for my data it should not be possible that the calculation evaluates to NULL in the first place.

               

              Many Thanks!

              - P

              1 of 1 people found this helpful
              • 4. Re: Calculated field boolean NULL
                Faris Ahamad M

                One method is :

                 

                Create a duplicate for the calculated field.

                Put The calculated field "is overdue" as context filter and deselect "Null" in that .

                Create a duplicate for the calculated field "is overdue" (say "is overdue (copy)"). Put that in the filter shelf.

                In the filter select the option "only Relevant Values"

                 

                Hide Filter card for "is overdue and use  "is overdue (copy)" after renaming it.

                1 of 2 people found this helpful