9 Replies Latest reply on Dec 27, 2016 6:15 AM by Maciek La

    Simple graph not working

    Eliza James

      Hi, I'm brand new to tableau and can't seem to replicate a simple graph originally created in Excel.

       

      I've attached a spreadsheet with the original data column headings (and some of the financial data), I had to change the columns slightly in an attempt to capture the months correctly and I've added tabs with what I've done so far in Tableau and finally the graphs I'm actually trying to achieve.

       

      It seems like it should be really simple but I must be doing something so wrong, any advice you have would be so appreciated!!!

        • 1. Re: Simple graph not working
          Maciek La

          Hi Eliza!

          Don't worry - each of us was new to Tableau

           

          I took the liberty to reshape your initial data slightly for ease of use:

           

          monthtypeflagmeasure1measure2measure3
          2016-07-01ActualsJul_Act788,43281265,690
          2016-08-01ActualsAug_Act86260,51299860,460
          2016-09-01ActualsSep_Act170070,5786005,460
          2016-10-01ActualsOct_Act131231,4601568,020
          2016-11-01ActualsNov_Act125610,982948869,6734533
          2016-12-01ActualsDec_Act0-1283075,2-34533
          2017-01-01ActualsJan_Act000
          2017-02-01ActualsFeb_Act000
          2017-03-01ActualsMar_Act000
          2017-04-01ActualsApr_Act000
          2017-05-01ActualsMay_Act000

           

          I've created 2 calculated fields:

          ValuesSum

          [measure1]+[measure2]+[measure3]

           

          ValuesSumCumulative

          RUNNING_SUM(sum([ValuesSum]))

           

          For the bars I just pulled month and type on the columns and Sum(ValuesSum) on the rows. Colors are handled by type on placed on the colors in Marks shelf

          forum20161212_2.PNG

           

          Lines chart uses more less the same idea but with dual axis:

           

          --

          if you find this post helpful please mark it as 'This helped me'/'Correct Answer' at the bottom of the post

          • 2. Re: Simple graph not working
            Eliza James

            Hi,

             

            Thanks so much for taking the time to look into this for me.  How did you shape the budget data?  Did you have to add it to the bottom and therefore duplicate the months etc???

             

               

            July 16Jul_Act032082190
            August 16Aug_Act880000500000
            September 16Sep_Act1000001906611500000

             

            monthtypeflagmeasure1measure2measure3
            2016-07-01ActualsJul_Act788,43281265,690
            2016-08-01ActualsAug_Act86260,51299860,460
            2016-09-01ActualsSep_Act170070,5786005,460
            2016-10-01ActualsOct_Act131231,4601568,020
            2016-11-01ActualsNov_Act125610,982948869,6734533
            2016-12-01ActualsDec_Act0-1283075,2-34533
            2017-01-01ActualsJan_Act000
            2017-02-01ActualsFeb_Act000
            2017-03-01ActualsMar_Act000
            2017-04-01ActualsApr_Act000
            2017-05-01ActualsMay_Act00

            0

            • 3. Re: Simple graph not working
              Maciek La

              Exactly,

              I've duplicated months and differentiate them with new type = budget.

               

              • 4. Re: Simple graph not working
                Eliza James

                Thanks for responding.

                 

                Do you know if I can filter based on the 3 measures?  I'm not sure how to do this because the graphs are based on the calculated fields.  I want to put a filter on the sheet that the user could change.

                 

                Sorry for all the questions!

                • 5. Re: Simple graph not working
                  Maciek La

                  It doesn't matter if it's a calculated field. Pull the field to the filter shelf and theb right click on it > show filter

                   

                  • 6. Re: Simple graph not working
                    Eliza James

                    Thanks, I tried that by pulling the Measure Names on the filter but the data doesn't change when I select different items.

                     

                    • 7. Re: Simple graph not working
                      Maciek La

                      Don't pull measure names to filters

                      Measure names allows you to filter Measure names (duh!) not values. Meaning that, when you pulled it to the filters then you could select what measures you will see on the graph, not the range of values.

                      Pull ValueSum to filters if you want to see specific Value range. If you pull type, then you will have Budget/Actual Selector, if you pull month, then you will have month selector, etc.

                      What filter exactly you would like to have in place? What is the question you want to answer here?

                      • 8. Re: Simple graph not working
                        Eliza James

                        The value sum is made up of 3 measures.  I want to be able to filter on each measure individually, 2 at a time or all 3.

                        • 9. Re: Simple graph not working
                          Maciek La

                          The only solution I can think of right now is to pull measures that sum up to ValueSum on the filter shelf

                          this way you can efficiently filter each of the 3 elements that ValueSum consists of. If you don't want to filter by measure 2 you simply don't change the slider..